Internal Server Error when adding invalid SSH keys

Bug #1298788 reported by Julian Edwards on 2014-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Raphaël Badin

Bug Description

Adding an invalid SSH key using /MAAS/account/prefs/sshkey/add/ results in an internal server
error when the submitted key is short and contains a single quote. For example ssh-rsa ‘. Attempting
to add the same key using the API causes the error message ‘unpack requires a string argument
of length 4’.

Related branches

Raphaël Badin (rvb) wrote :

I can't reproduce that. I think this is a duplicate of bug 1298788 and it's been already fixed.
However, while fiddling with wrongly formatted ssh keys, I found that submitting 'ssh-r' triggers an error (http://paste.ubuntu.com/7168866/).

Raphaël Badin (rvb) on 2014-03-28
Changed in maas:
assignee: nobody → Raphaël Badin (rvb)
status: Triaged → In Progress
Raphaël Badin (rvb) on 2014-03-31
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers