ValueError using lxml when evaluating tags in worker

Bug #1237463 reported by Gavin Panella on 2013-10-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Gavin Panella
maas (Ubuntu)
Critical
Unassigned

Bug Description

Observed with maas 1.4+bzr1676+dfsg-0+1689+209~ppa0~ubuntu13.10.1 from the daily PPA on the Garage MAAS:

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/celery/execute/trace.py", line 181, in trace_task
    R = retval = fun(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/provisioningserver/tasks.py", line 365, in update_node_tags
    tags.process_node_tags(tag_name, tag_definition, tag_nsmap)
  File "/usr/lib/python2.7/dist-packages/provisioningserver/tags.py", line 371, in process_node_tags
    batch_size=batch_size)
  File "/usr/lib/python2.7/dist-packages/provisioningserver/tags.py", line 339, in process_all
    partial(try_match_xpath, xpath, logger=logger), node_details)
  File "/usr/lib/python2.7/dist-packages/provisioningserver/utils.py", line 668, in classify
    for ident, subject in subjects:
  File "/usr/lib/python2.7/dist-packages/provisioningserver/tags.py", line 324, in gen_node_details
    yield system_id, merge_details(details)
  File "/usr/lib/python2.7/dist-packages/provisioningserver/tags.py", line 256, in merge_details
    return _details_do_merge(details, root)
  File "/usr/lib/python2.7/dist-packages/provisioningserver/tags.py", line 218, in _details_do_merge
    detail = etree.fromstring(xmldata)
  File "lxml.etree.pyx", line 2993, in lxml.etree.fromstring (src/lxml/lxml.etree.c:62980)
  File "parser.pxi", line 1607, in lxml.etree._parseMemoryDocument (src/lxml/lxml.etree.c:92730)
ValueError: Unicode strings with encoding declaration are not supported. Please use bytes input or XML fragments without declaration.

Related branches

Gavin Panella (allenap) on 2013-10-09
description: updated
Gavin Panella (allenap) wrote :

The cause of this is bug 1237615.

Raphaël Badin (rvb) on 2013-10-11
Changed in maas:
assignee: nobody → Gavin Panella (allenap)
status: In Progress → Fix Committed
Gavin Panella (allenap) on 2013-10-11
Changed in maas:
milestone: none → 13.10
Changed in maas (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.4+bzr1693+dfsg-0ubuntu2

---------------
maas (1.4+bzr1693+dfsg-0ubuntu2) saucy; urgency=low

  * debian/patches:
    - 99_fix_wsgi_app_group_lp1237463.patch: Import wsgi into the %{GLOBAL}
      application group, to avoid bson encoding issues. (LP: #1237463)
    - 99_ephemeral_backward_compat_lp1238376.patch: Maintain import_ephemerals
      config compatibility to allow maas-import-ephemerals to inherit the
      config used for maas-import-pxe-files, otherwise it will always download
      all releases even when set to a particular one. (LP: #1238376)
    - 99_split_config_arch_rel_lp1238681.patch: arches/releases are a list
      of characters that need to be split. (LP: #1238681)
    - 99_handle_ephemeral_archs_correctly.patch: Allow maas-import-ephemerals
      to use arches correctly coming from the legacy config (LP: #1240215)
 -- Andres Rodriguez <email address hidden> Mon, 14 Oct 2013 13:10:21 -0400

Changed in maas (Ubuntu):
status: Confirmed → Fix Released
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers