MAAS_URL on maas_cluster.conf is quoted on quantal but not quoted on raring

Bug #1172303 reported by Diogo Matsubara on 2013-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Undecided
Diogo Matsubara

Bug Description

I've seen this error on raring cluster controller tests:

MismatchError: "MAAS_URL='http://192.168.21.5/MAAS'" not in '# This file is used by the cluster controller startup script:\n# `maas-provision start-cluster-controller`\n# to get the URL to the MAAS region controller\'s API. Normally, packaging\n# will update this file automatically but it may also be configured manually.\nMAAS_URL=http://192.168.21.5/MAAS\nCLUSTER_UUID="f0c4cb78-6274-4c4f-b951-1b201daa99d2"\n'

The MAAS_URL value is not quoted while the test expects it to be quoted. This test passes on quantal.

Related branches

Diogo Matsubara (matsubara) wrote :

https://pastebin.canonical.com/89838/ this would fix the tests but we need to find out the root cause, which is likely related to the packaging branch

Changed in maas:
assignee: nobody → Andres Rodriguez (andreserl)
Changed in maas:
assignee: Andres Rodriguez (andreserl) → nobody
Jeroen T. Vermeulen (jtv) wrote :

I've been looking for the cause and didn't see it, but that may be because it's already been fixed by this merge proposal: https://code.launchpad.net/~matsubara/maas/fix-MAAS_URL-quotes-precise/+merge/160725

If I'm right, can we link that branch to this bug, and close the bug?

Changed in maas:
status: New → Fix Committed
assignee: nobody → Diogo Matsubara (matsubara)
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers