IPMI based power management default to IPMI 1.5 based authentication

Bug #1086162 reported by Kiran on 2012-12-03
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
MAAS
High
Andres Rodriguez
1.2
High
Andres Rodriguez
maas (Ubuntu)
High
Andres Rodriguez

Bug Description

ipmi.template - {ipmipower} defaults to IPMI 1.5 based authentication. HP iLO support only IPMI 2.0 based authentication. IPMI command fails.
Error Message: authentication type unavailable for attempted privilege level

IPMI command need to explicitly specify the --driver-type=LAN_2_0

Related branches

Kiran (ramineni) on 2012-12-03
description: updated
Darryl Weaver (dweaver) wrote :

I ran into the same issue.
The IPMI commands fail to start the servers.
Modifying the line 47 of /usr/lib/python2.7/dist-packages/provisioningserver/power/templates/ipmi.template to read:
    ${ipmipower} --driver-type=LAN_2_0 -h ${power_address} -u ${power_user} -p ${power_pass} "$@"
Seems to fix the problem for my lab set up.

Darryl Weaver (dweaver) wrote :

Hardware in our Lab:

1 x HP ProLiant DL380 G7 Running KVM Virtual Servers using bridged networking.
Ubuntu 12.10 Server install with maas version 0.1+bzr1269+dfsg-0ubuntu1

The nodes registered to the maas server are 12 x HP ProLiant SL390s G7 which have HP iLO 3 Standard Version 1.28.

Behaviour: Nodes are booted and enlisted to MAAS, but are not started for commissioning when accepted into MAAS.
If started manually and commissioned into ready state, the commissioning process stores the ILO login credentials correctly, but still cannot start the server.

We found that the provided fix by Kiran fixed the problem for us and once the below edit was made, the MAAS server was able to correctly start and stop the nodes on demand.

ipmi.template.orig:
47: ${ipmipower} -h ${power_address} -u ${power_user} -p ${power_pass} "$@"

ipmi.template.new
47: ${ipmipower} --driver-type=LAN_2_0 -h ${power_address} -u ${power_user} -p ${power_pass} "$@"

Darryl Weaver (dweaver) on 2012-12-06
Changed in maas:
status: New → Confirmed
Kiran (ramineni) wrote :

Thanks Darryl.
Tested the fix against Dell: dell 2950 & dell 610 (latest firms upgrades), HP Proliants (10/2012 firmware upgrades). fix worked with dell & HPs

Dave Walker (davewalker) on 2012-12-08
Changed in maas:
assignee: nobody → Andres Rodriguez (andreserl)
importance: Undecided → High
Changed in maas (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
Changed in maas:
assignee: Andres Rodriguez (andreserl) → nobody
Changed in maas (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in maas:
status: Confirmed → Triaged
tags: added: power
Raphaël Badin (rvb) on 2012-12-20
Changed in maas:
assignee: nobody → Andres Rodriguez (andreserl)
status: Triaged → Fix Committed
status: Fix Committed → Triaged
Changed in maas:
status: Triaged → Fix Committed
Raphaël Badin (rvb) wrote :

I'm reverting the fix for this and re-opening the bugs because the fix broke our integration test suite in the QALab; it made MAAS unable to power up the machines. If we need support for both IPMI 1.5 and IPMI 2.0 at the same time, I suggest we do something along the lines of: http://paste.ubuntu.com/1454885/

Changed in maas:
status: Fix Committed → Triaged
Andres Rodriguez (andreserl) wrote :

Changing to Fix Released as another method was used to fix this.

Changed in maas (Ubuntu):
status: Triaged → Fix Released
Yazz D. Atlas (entropyworks) wrote :

I'm currently using maas 0.1+bzr1269+dfsg-0ubuntu1 and the work around I have is to modify /etc/freeipmi/freeipmi.conf and add one line.

driver-type LAN_2_0

This will be passed to ipmipower without changing the code. Just passing the info along if others run into this before the fix makes it out the the general public

Raphaël Badin (rvb) on 2014-05-09
Changed in maas:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers