Oops when renaming nodegroup w/o interface

Bug #1077075 reported by Jeroen T. Vermeulen on 2012-11-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Jeroen T. Vermeulen
1.2
High
Jeroen T. Vermeulen

Bug Description

The UI oopses when you change the name of an accepted nodegroup that has no interfaces.

The reason is that NodeGroupEdit.clean_name assumes that NodeGroup.get_managed_interface returns an interface. If it returns None under these narrow circumstances, the code breaks.

(This is easy to reproduce in a dev branch: just rename the master nodegroup).

Related branches

description: updated
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints