maas-dns changes default bind rndc key and breaks initscripts

Bug #1066938 reported by Zygmunt Krynicki on 2012-10-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Raphaël Badin
maas (Ubuntu)
Critical
Andres Rodriguez
Precise
Undecided
Unassigned

Bug Description

The default install of maas-dns creates the following file /etc/bind/maas/rndc.conf.maas

Among it are the following two bind9 configuration sections:

key "rndc-maas-key" {
 algorithm hmac-md5;
 secret "(edited away)";
};

options {
 default-key "rndc-maas-key";
 default-server 127.0.0.1;
 default-port 954;
};

This breaks init scripts (sudo service bind9 restart) as they use the key called "rndc-key". I would suggest that maas explicitly provide the key that it wishes to use whenever it interacts with bind9 so that defaults don't have to change

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: maas-dns 0.1+bzr1264+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
ApportVersion: 2.6.1-0ubuntu3
Architecture: i386
Date: Mon Oct 15 17:15:31 2012
InstallationMedia: Ubuntu-Server 12.10 "Quantal Quetzal" - Release i386 (20121014)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: maas
UpgradeStatus: No upgrade log present (probably fresh install)

== TEST ==
This fix has been tested on both canonistack and in the lenovo lab.

Related branches

Zygmunt Krynicki (zyga) wrote :
Raphaël Badin (rvb) wrote :

> I would suggest that maas explicitly provide the key that it wishes to use whenever it interacts with bind9 so that defaults don't
> have to change

Looks like a very good idea to me.

affects: maas (Ubuntu) → maas
Changed in maas:
importance: Undecided → Critical
status: New → Triaged
Changed in maas:
milestone: none → 12.10
Raphaël Badin (rvb) on 2012-10-16
Changed in maas:
assignee: nobody → Raphaël Badin (rvb)
status: Triaged → In Progress
Raphaël Badin (rvb) on 2012-10-16
Changed in maas:
status: In Progress → Fix Committed
tags: added: sru-12.10
Changed in maas:
status: Fix Committed → Fix Released
Changed in maas (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
importance: Undecided → Critical
status: New → In Progress
description: updated
Raphaël Badin (rvb) on 2012-10-18
Changed in maas (Ubuntu):
status: In Progress → Fix Committed

Hello Zygmunt, or anyone else affected,

Accepted into quantal-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 0.1+bzr1269+dfsg-0ubuntu1

---------------
maas (0.1+bzr1269+dfsg-0ubuntu1) quantal-proposed; urgency=low

  * New upstream bugfix release
    - Fixes commissioning failing to set memory attribute. (LP: #1064638)
    - Fixes node listing by adding pagination (LP: #1064672)
    - Changes default bind rndc key which breaks initscripts (LP: #1066938)
    - Fixes invalid DNS config once node is enlisted (LP: #1066958)
    - Reference documentation link to correct URL (LP: #1067261)

  [ Andres Rodriguez ]
  * debian/rules: Change upstream branch.

  [ Gavin Panella ]
  * debian/maas-dns.postinst: Remove MAAS-related include lines from named's
    config before adding a new one (LP: #1066929)

  [ Raphael Badin ]
  * debian/extras/maas-region-celeryd: Remove whitespace that affects DNS
    rabbitmq queue. (LP: #1067929)
 -- Andres Rodriguez <email address hidden> Tue, 16 Oct 2012 10:31:37 -0400

Changed in maas (Ubuntu):
status: Fix Committed → Fix Released
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Dave Walker (davewalker) on 2012-10-26
Changed in maas (Ubuntu Precise):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers