ARM: Power parameters fail to get set when using Quantal ephemerals

Bug #1065499 reported by Robie Basak
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Scott Moser

Bug Description

Using maas 0.1+bzr1243+dfsg-0ubuntu3, installed this morning.

I additionally imported Quantal images by editing /etc/maas/import_pxe_files and adding quantal to RELEASES before running sudo maas-import-pxe-files. Then I set "Default distro series used for commissioning" to Quantal using the Web UI.

Enlisting a node does not set power parameters. The console output suggests that power parameters were not sent (empty string).

Commissioning a node also does not set power parameters. I see this during commissioning:

 Setting up freeipmi-tools (1.1.5-3ubuntu2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Traceback (most recent call last):
  File "/tmp/part-001.iniXie/bin/maas-signal", line 262, in <module>
    main()
  File "/tmp/part-001.iniXie/bin/maas-signal", line 227, in main
    power_pass=args.power_parms.split(",")[1],
IndexError: list index out of range
Success
Success
Success
Finished, powering off.

This does not occur using Precise ephemerals. Note that for Precise to work on highbank, I have to add ppa:maas-maintainers/dailybuilds to the enlistment userdata, since highbank detection requires the maas-enlist SRU which hasn't landed yet. As expected without the latest maas-enlist, power parameters only get set in commissioning, not in enlistment.

Tags: arm Edit Tag help

Related branches

Changed in maas:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Andres Rodriguez (andreserl)
milestone: none → 12.10
Revision history for this message
Robie Basak (racb) wrote :

The cause for this is that ipmi-locate output between precise and quantal is different on highbank. In fact, on quantal ipmi-locate appears to no longer work.

A workaround Scott and I have discussed is to look for /dev/ipmi0 after the existing logic detects nothing. This appears to be sufficient on highbank, and doesn't give me a false positive on my (non-IPMI) machine.

Revision history for this message
Robie Basak (racb) wrote :
Revision history for this message
Robie Basak (racb) wrote :
Revision history for this message
Scott Moser (smoser) wrote :

kernel messages from a ipmi-locate failed run on quantal show:

backdoor@maas-enlisting-node:~$ dmesg | grep -i ipmi
ipmi message handler version 39.2
ipmi device interface
ipmi_si fff3a000.smic: probing via device tree
ipmi_si: Adding device-tree-specified smic state machine
IPMI System Interface driver.
ipmi_si: Trying device-tree-specified smic state machine at mem address 0xfff3a000, slave address 0x0, irq 56
ipmi_si fff3a000.smic: Using irq 56
ipmi_si fff3a000.smic: Found new BMC (man_id: 0x000444, prod_id: 0x0000, dev_id: 0x00)
ipmi_si fff3a000.smic: IPMI smic interface initialized
Program ipmi-locate tried to access /dev/mem between f0000->100000.
Program ipmi-locate tried to access /dev/mem between f0000->100000.
Program ipmi-locate tried to access /dev/mem between f0000->100000.
Program ipmi-locate tried to access /dev/mem between f0000->100000.
Program ipmi-locate tried to access /dev/mem between f0000->100000.
Program ipmi-locate tried to access /dev/mem between f0000->100000.
Program ipmi-locate tried to access /dev/mem between f0000->100000.
Program ipmi-locate tried to access /dev/mem between f0000->100000.
Program ipmi-locate tried to access /dev/mem between 0->1000.
Program ipmi-locate tried to access /dev/mem between e0000->100000.
Program ipmi-locate tried to access /dev/mem between 0->1000.
Program ipmi-locate tried to access /dev/mem between e0000->100000.
Program ipmi-locate tried to access /dev/mem between 0->1000.
Program ipmi-locate tried to access /dev/mem between e0000->100000.
Program ipmi-locate tried to access /dev/mem between 0->1000.
Program ipmi-locate tried to access /dev/mem between e0000->100000.
Program ipmi-locate tried to access /dev/mem between 0->1000.
Program ipmi-locate tried to access /dev/mem between e0000->100000.
Program ipmi-locate tried to access /dev/mem between 0->1000.
Program ipmi-locate tried to access /dev/mem between e0000->100000.
Program ipmi-locate tried to access /dev/mem between 0->1000.
Program ipmi-locate tried to access /dev/mem between e0000->100000.
Program ipmi-locate tried to access /dev/mem between 0->1000.
Program ipmi-locate tried to access /dev/mem between e0000->100000.
Program ipmi-locate tried to access /dev/mem between 0->1000.
Program ipmi-locate tried to access /dev/mem between e0000->100000.

summary: - Power parameters fail to get set when using Quantal ephemerals
+ ARM: Power parameters fail to get set when using Quantal ephemerals
Changed in maas:
assignee: Andres Rodriguez (andreserl) → nobody
assignee: nobody → Scott Moser (smoser)
Robie Basak (racb)
tags: added: arm
Changed in maas:
status: Triaged → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers