ElementInclude false detection of recursive include

Bug #1835708 reported by Rainer Hausdorf on 2019-07-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lxml
Low
Unassigned

Bug Description

Python : sys.version_info(major=3, minor=7, micro=3, releaselevel='final', serial=0)
lxml.etree : (4, 3, 4, 0)
libxml used : (2, 9, 9)
libxml compiled : (2, 9, 9)
libxslt used : (1, 1, 33)
libxslt compiled : (1, 1, 33)

In some cases ElementInclude of lxml does raise FatalIncludeError because of recursive include detection, when the same file gets included multiple times, but not recursive. I provided a minimal example. The xinclude does work.

Rainer Hausdorf (rhx84) wrote :
scoder (scoder) wrote :

PR welcome that improves the include handling.

Changed in lxml:
importance: Undecided → Low
status: New → Confirmed
Rainer Hausdorf (rhx84) wrote :
scoder (scoder) wrote :
Changed in lxml:
status: Confirmed → Fix Committed
milestone: none → 4.4.2
scoder (scoder) on 2019-12-27
Changed in lxml:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments