3.6.2 refers to undefined symbol in .so file

Bug #1614603 reported by Eddie Welker on 2016-08-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lxml
High
scoder

Bug Description

Just trying to import etree fails with the new 3.6.2 release pushed to PyPI this morning.

```
from lxml import etree
E ImportError: /export/home/tomcat/TeamCity/Agent1/work/83f8e92ce6d42a47/.tox/py34/lib/python3.4/site-packages/lxml/etree.cpython-34m.so: undefined symbol: clock_gettime
```

```
(venv) [2087] welkere@host:~ $ ls -l /usr/lib/libx{m,s}*
lrwxrwxrwx 1 root root 16 Jun 24 10:09 /usr/lib/libxml2.so.2 -> libxml2.so.2.7.6*
-rwxr-xr-x 1 root root 1352268 Jun 23 04:51 /usr/lib/libxml2.so.2.7.6*
lrwxrwxrwx. 1 root root 17 Sep 24 2014 /usr/lib/libxslt.so.1 -> libxslt.so.1.1.26*
-rwxr-xr-x. 1 root root 242784 Sep 13 2012 /usr/lib/libxslt.so.1.1.26*
```

description: updated
description: updated
description: updated
scoder (scoder) wrote :

What Linux distribution and version is this?

Eddie Welker (eddie-welker) wrote :

CentOS6, however I found that it works on CentOS7.

BJV (ertcorp) (bjv-ert) wrote :

encountering same issue, when upgrading from 3.6.1 to lxml-3.6.2-cp34-cp34m-manylinux1_x86_64.whl

distro: CentOS 6.8 (glibc 2.12)

scoder (scoder) wrote :

Thanks. The man page of "clock_gettime()" (which is used by libxslt) says that it requires linking with "-lrt" before glibc 2.17. Seems to work also with newer versions, though, so I'll add that to the list of shared libraries and rebuild. I'll remove the wheels for now.

scoder (scoder) wrote :

New wheels uploaded for lxml 3.6.3. Let's see if those work better.

Eddie Welker (eddie-welker) wrote :

Well, at least from the interpreter, 3.6.3 seemed to have fixed it. I'll add that to the application too.

Eddie Welker (eddie-welker) wrote :

Yep, worked like a charm. Thank you so much scoder!!!

scoder (scoder) wrote :

You're welcome. Thanks for the quick report.

Changed in lxml:
assignee: nobody → scoder (scoder)
importance: Undecided → High
milestone: none → 3.6.3
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers