XSLTAccessControl.__repr__ fails with AttributeError

Bug #1228881 reported by Pieter Nagel
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lxml
Fix Released
Low
scoder

Bug Description

To reproduce the bug:

>>> from lxml.etree import XSLTAccessControl
>>> repr(XSLTAccessControl.DENY_ALL)
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "xslt.pxi", line 250, in lxml.etree.XSLTAccessControl.__repr__ (src/lxml/lxml.etree.c:137775)
AttributeError: 'dict_items' object has no attribute 'sort'

This is a problem, because the PyCharm IDE tries to instrospect the lxml package in order to assist with its public API, but due to the repr bug it is unable to do so.

Python : sys.version_info(major=3, minor=3, micro=1, releaselevel='final', serial=0)
lxml.etree : (3, 2, 3, 0)
libxml used : (2, 9, 0)
libxml compiled : (2, 9, 0)
libxslt used : (1, 1, 27)
libxslt compiled : (1, 1, 27)

Revision history for this message
scoder (scoder) wrote :

Thanks for the report. That's a typical Py3-only bug.

https://github.com/lxml/lxml/commit/7e50505d398c685d7c21934fcc5af8ed51f2a4d6

Changed in lxml:
assignee: nobody → scoder (scoder)
importance: Undecided → Low
milestone: none → 3.3
status: New → Fix Committed
Revision history for this message
scoder (scoder) wrote :

Fixed in lxml 3.2.4.

Changed in lxml:
milestone: 3.3 → none
status: Fix Committed → Fix Released
milestone: none → 3.2
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers