Luciole 0.9.1 crashes at startup

Bug #640823 reported by ianux on 2010-09-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Luciole
Status tracked in 0.9
0.9
High
Unassigned

Bug Description

:~$ luciole
** Message: pygobject_register_sinkfunc is deprecated (GtkWindow)
** Message: pygobject_register_sinkfunc is deprecated (GtkInvisible)
** Message: pygobject_register_sinkfunc is deprecated (GtkObject)
['/usr/bin', '/usr/lib/python26.zip', '/usr/lib/python2.6', '/usr/lib/python2.6/plat-linux2', '/usr/lib/python2.6/lib-tk', '/usr/lib/python2.6/lib-old', '/usr/lib/python2.6/lib-dynload', '/usr/lib/python2.6/site-packages', '/usr/lib/python2.6/site-packages/PIL', '/usr/lib/python2.6/site-packages/gst-0.10', '/usr/lib/python2.6/site-packages/gtk-2.0', '/usr/lib/python2.6/site-packages/wx-2.8-gtk2-unicode']
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
2010-09-16 23:00:42,479 - luciole - INFO -MainThread - (ctrl.py, 77) - Starting luciole
Traceback (most recent call last):
  File "/usr/bin/luciole", line 53, in <module>
    X.main()
  File "/usr/lib/python2.6/site-packages/luciole/main.py", line 39, in main
    runner = LC.LucioleController(sys.argv)
  File "/usr/lib/python2.6/site-packages/luciole/ctrl/ctrl.py", line 89, in __init__
    self.__gui = GUI_CTRL.GuiController(self.ctrl_signals)
  File "/usr/lib/python2.6/site-packages/luciole/gui/gui_ctrl.py", line 200, in __init__
    self._priv_signals)
  File "/usr/lib/python2.6/site-packages/luciole/gui/base/builder.py", line 102, in __init__
    self.__ui_objects[self.MAIN_WINDOW_NAME].show()
KeyError: 'window1'

I don't know if this is related, but I'm using Awesome WM

NicoInattendu (nico-inattendu) wrote :

Hi, I think you gave 2 problems.
One is the crash and it is due to gtk.builder modification. Is a duplicate of bug #507739. I fixed it for luciole after release 0.9.1. The code with correction is not released yet, planned for release 0.9.2. A commit correcting this issue is available in branch lp:luciole.

The other one is the waning messages on pygobject. I don't have, yet , those warnings on Ubuntu 10.04 . This is probably due to your version of pygobject or gobject.
For pygobject I have version 2.21.1-0ubuntu3, for gobject and a libglib2.0-0 version 2.24.0-0ubuntu4.
These problem can be due of your installed pacakge in WM. Which distro ?
But luciole does run correctly, even those warning

cheers

Changed in luciole:
status: New → Confirmed
importance: Undecided → High
tags: added: crash gui
ianux (ianux) wrote :

Hi,
gtkbuilder patch applied, it's working, thank you.
FYI, I'm using Archlinux with pygobject 2.21.3, glib 2.24.2 and python 2.6.5

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers