inkscape 0.48.2

Bug #844697 reported by Pander on 2011-09-08
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Lucid Backports
Undecided
Iain Lane
Natty Backports
Undecided
Unassigned
maverick-backports
Fix Released
Undecided
Iain Lane

Bug Description

Please backport inkscape_0.48.2-0ubuntu1 from Oneiric.

== Natty testing status ==
* inkscape_0.48.2-0ubuntu1 builds in amd64 pbuilder in natty (logs attached)
* Package installs and runs correctly
* All reverse dependencies run correctly

== Maverick testing status ==
* inkscape_0.48.2-0ubuntu1 fails to build in pbuilder: Missing dependencies
* It is possible to build and install inkscape 0.48.2 from upstream source without issues
* Source-change inkscape_0.48.2-0ubuntu1~maverick1 package builds in amd64 pbuilder (log attached)
* Package installs and runs correctly
* All reverse dependencies run correctly

== Lucid testing status ==
* Source-change inkscape_0.48.2-0ubuntu1~maverick1 package builds in amd64 pbuilder (log attached)
* Package installs and runs correctly
* All reverse dependencies run correctly

 affects natty-backports

Hiya,

On Thu, Sep 08, 2011 at 11:16:05AM -0000, Pander wrote:
> Public bug reported:
>
> Please backport inkscape 0.48.2
>
> It is possible to build and install it from source without issues.

Thanks for the report. To backport from Oneiric to Maverick we'll need
to also backport to Natty. Are you able to test it works there too?
(same for your other request)

Cheers,

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]
PhD student [ <email address hidden> ]

Pander (pander) wrote :

I can only test Maverick.

Alex Valavanis (valavanisalex) wrote :

I'll take a look at natty and attach buildlogs shortly.

Alex Valavanis (valavanisalex) wrote :

Natty 64-bit pbuilder build completed successfully. Buildlog attached

Alex Valavanis (valavanisalex) wrote :

Natty 64-bit build installs and runs fine.

Alex Valavanis (valavanisalex) wrote :

Attaching a deb for natty 64-bit for testing

On Thu, Sep 08, 2011 at 11:43:43PM -0000, Alex Valavanis wrote:
> Natty 64-bit build installs and runs fine.

Great, could you quickly check that the reverse dependencies I mentioned
to you on IRC (sorry, I don't remember offhand exactly which they were)
still work with the newer Inkscape? We'll then be good to go for the
backport :-)

Thanks for testing.

Cheers,

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]
PhD student [ <email address hidden> ]

Alex Valavanis (valavanisalex) wrote :

Hi Iain,

I'll check the rdepends as soon as I can. However, I'm working overseas for a couple of weeks, so my response might not be particularly speedy! I had a quick check after our discussion, and it looks like there may be a couple more reverse dependencies to investigate. I will report back as soon as I can.

Were you thinking of backporting only to Natty first, or to Maverick & Natty at the same time? I haven't performed any Maverick checks at all yet.

Alex Valavanis (valavanisalex) wrote :

inkscape_0.48.2-0ubuntu1 fails to build in Maverick pbuilder, unfortunately [see attached buildlog]. There are a few unmet dependencies:

* dh_translations
* libwpd-dev (>= 0.9.0)
* libwpg-dev (>= 0.2.0)

It shouldn't be too difficult to fix this, however:

* dh_translations can be dropped in favour of the old-fashioned manual patching method.
* Upstream inkscape should now build cleanly with any version of the libwp*-dev packages, so we can just drop the versioning on these dependencies.

In the meantime, shall we just focus on getting the Natty backport sorted first? I'll check the reverse-dependencies shortly.

Pander (pander) wrote :

Maverick builds very easily from source so the backport shouldn't be too much trouble as you indicate.

Alex Valavanis (valavanisalex) wrote :

Reverse-dependency listing for natty:

$ apt-cache rdepends --no-suggests inkscape
inkscape
Reverse Depends:
  zoomer
  ubuntustudio-graphics
  ubuntu-edu-tertiary
  ubuntu-edu-secondary
  open-font-design-toolkit
  ink-generator
  gnome-office
  ezgo-imaging
  brdesktop-gnome

(Please let me know if you'd like "suggests" dependencies to be included too)

Alex Valavanis (valavanisalex) wrote :

All reverse dependencies for Natty run successfully. Please consider processing the Natty backport.

* zoomer (Depends)
>> Example at http://wiki.colivre.net/Aurium/Zoomer runs successfully

* ink-generator (Depends)
>> Tested simple 2-variable text substitution using method at http://wiki.colivre.net/Aurium/InkscapeGenerator

The following are all just metapackages. No need for testing.
* ubuntustudio-graphics, open-font-design-toolkit, gnome-office (Depends)
* ubuntu-edu-tertiary, ubuntu-edu-secondary, ezgo-imaging, brdesktop-gnome (Recommends)

Changed in natty-backports:
status: New → Confirmed
description: updated
Iain Lane (laney) wrote :

Great! Ack from ubuntu-backports for the natty-backports task. Thanks for your testing.

For M, do you want to prepare the debdiff for the source changes? If not, I can do that but I might need some help testing as I don't have a Maverick environment to hand.

Changed in natty-backports:
status: Confirmed → In Progress
Alex Valavanis (valavanisalex) wrote :

I can take a look at maverick early next week, but if you get there first then I'll certainly help with testing. Thanks!

Alex Valavanis (valavanisalex) wrote :

Maverick version committed to lp:~valavanisalex/maverick-backports/fix-844697. Debdiff attached.

description: updated
Alex Valavanis (valavanisalex) wrote :

Log for successful pbuilder build of inkscape_0.48.2-0ubuntu1~maverick1 attached

description: updated
description: updated
Iain Lane (laney) wrote :

Patch looks sane. What's the reason for those BD versions? If they are truly unnecessary then they should be dropped in the development package too.

Needs testing - zoomer, ink-generator, lyx (alternate depends with rsvg)

Alex Valavanis (valavanisalex) wrote :

Hi, the B-D versions for wpg/wpd are no longer necessary... it's a legacy of a now-defunct patch, so we can now drop them.

If you're interested, the rough timeline is as follows:

1. Upstream inkscape <= 0.48.1 depends on wpg-0.1.0

2. Debian introduces wpg-0.2.0

3. Debian Inkscape package 0.48.1-2 introduces new patch to build Inkscape against wpg-0.2.0. B-D versions introduced. http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=604825

4. Upstream inkscape 0.48.2 released: builds against either wpg-0.1.0 or 0.2.0

5. (No Debian package of 0.48.2 yet)

6. Ubuntu package 0.48.2-0ubuntu1 drops wpg patch (better patch now upstream). B-D versions not dropped.

Alex Valavanis (valavanisalex) wrote :

Maverick 64-bit version of inkscape_0.48.2-0ubuntu1~maverick1 installs and runs correctly. Deb attached.

Alex Valavanis (valavanisalex) wrote :

Maverick reverse-dependencies listing:

$ apt-cache rdepends inkscape --no-suggests
inkscape
Reverse Depends:
  zoomer
  ubuntustudio-graphics
  ubuntu-edu-tertiary
  ubuntu-edu-secondary
  open-font-design-toolkit
  lyx
  ink-generator
  gnome-office
  ezgo-imaging
  brdesktop-gnome

Alex Valavanis (valavanisalex) wrote :

* zoomer (Depends)
>> Example at http://wiki.colivre.net/Aurium/Zoomer runs successfully

* ink-generator (Depends)
>> Tested simple 2-variable text substitution using method at http://wiki.colivre.net/Aurium/InkscapeGenerator

* lyx (Recommends)
>> Tested import of SVG image using method at http://wiki.lyx.org/Tips/UseInkscapeSVGImages#Inkscape (note that the package already configures lyx correctly)

The rest are all just metapackages. No need for testing.

description: updated
Iain Lane (laney) wrote :

Awesome, ack for maverick too then :-)

Changed in maverick-backports:
status: New → In Progress
Alex Valavanis (valavanisalex) wrote :

Thanks! I'm running a build of inkscape_0.48.2-0ubuntu1~maverick1 in lucid. I'll let you know how it goes.

I guess there's not much point going for Hardy too, is there?

Iain Lane (laney) wrote :

I wouldn't bother, it's not supported for the desktop any more

Alex Valavanis (valavanisalex) wrote :

Successful build of inkscape_0.48.2-0ubuntu1~maverick1 in lucid amd64 pbuilder. Log attached

description: updated
Alex Valavanis (valavanisalex) wrote :

Deb package of inkscape_0.48.2-0ubuntu1~maverick1 installs and runs correctly in lucid amd64.

Reverse dependency analysis for lucid:

* zoomer (Depends)
>> Example at http://wiki.colivre.net/Aurium/Zoomer runs successfully

* ink-generator (Depends)
>> Tested simple 2-variable text substitution using method at http://wiki.colivre.net/Aurium/InkscapeGenerator

description: updated
Iain Lane (laney) wrote :

Alright, thanks! Can you add a lucid-backports debdiff? Target lucid-backports and version suffix ~lucid1, then we'll be done. Great work :-)

Alex Valavanis (valavanisalex) wrote :

Lucid backport debdiff as requested. Bzr branch is on its way if you need that too.

Iain Lane (laney) wrote :

Nah, not necessary. Thanks: ack for lucid-backports. I'll upload these diffs once the natty backport is processed.

***********************************

**ARCHIVE ADMIN: Please do a no-change backport for natty ONLY. Maverick and Lucid REQUIRE SOURCE CHANGES which I will upload subsequently**

***********************************

Changed in maverick-backports:
assignee: nobody → Iain Lane (laney)
Changed in lucid-backports:
assignee: nobody → Iain Lane (laney)
status: New → In Progress
Colin Watson (cjwatson) wrote :

I: Extracting inkscape_0.48.2-0ubuntu1.dsc ... done.
I: Building backport of inkscape as 0.48.2-0ubuntu1~natty1 ... done.

Changed in natty-backports:
status: In Progress → Fix Released
Scott Kitterman (kitterman) wrote :

Accepted for Lucid.

Changed in lucid-backports:
status: In Progress → Fix Released
Scott Kitterman (kitterman) wrote :

Accepted for Maverick.

Changed in maverick-backports:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.