[test-pkg-a] Please backport VLC 1.1.4-1ubuntu1

Bug #607505 reported by Ken Phillis Jr on 2010-07-19
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Lucid Backports
Undecided
Unassigned

Bug Description

The latest version of VLC includes support for GPU accelerated decode of high bitrate codecs (like h264) and Youtube network stream and to meet the requirements the following packages will probably need updating.

ffmpeg v0.6. (Required to use libVA.)
x264 v:0.98 (required for ffmpeg v0.6)
libva v0.31.1

Steve Stalcup (vorian) wrote :

Hi Ken,

Can you please give results on the following:

1) Build results
2) Specific changes to the source package needed, if any
3) Installation results
4) Does it run properly?

https://help.ubuntu.com/community/UbuntuBackports will provide additional information on accomplishing these items.

Thanks!
Steve

Changed in lucid-backports:
status: New → Incomplete
Ken Phillis Jr (kphillisjr) wrote :

Here's the build logs for all of the packages that needed to be built to install vlc 1.1.1 (latest from the maverik repository). The only package which was not found in the maverik package repository was libva and it's related packages (This is available in the debian sid package repository or debian squeeze package repository )

the correct order of package installation is... libva libvpx ffmpeg x264 libmodplug vlc ... as for the dependencies besides these, I built the source against whatever packages/versions that are included within the lucid package repository.

Also, libva in the debian package repository is a little out of date... see the official development site for the latest release... however the dev repository has an outdated copy of the debian package scripts.
http://freedesktop.org/wiki/Software/vaapi

final notes... the libffmpeg, x264 and vlc will need updates to the dependencies to automatically install libva if that package is pulled into the repository.

Steve Stalcup (vorian) wrote :

Any software in Debian would have to be sync'd before we could even consider a backport. There would also have to be a sync request to get the missing dependencies from Debian to Maverick then back to Lucid. With Feature Freeze looming (thursday is the day), there's not much time to get it all done.

You will need to:
File a sync request for each package that is missing in Maverick, an update or sync for each version in Debian that is HIGHER than Karmic.

I will also have to look into why those missing packages weren't auto-synced to begin with.

Steve Stalcup (vorian) wrote :

I meant to say that any version you are using from Debian that is a HIGHER version than Maverick would need updated or synced in Maverick.

Ken Phillis Jr (kphillisjr) wrote :

It's a completely missing package... Anyways, i went ahead and put up the bug report for this (Bug #614914 )

Steve Stalcup (vorian) wrote :

To get a package into Ubuntu, you have to request a sync after the Debian import freeze. Getting that approved and all the other changes are the next step. This may be something that will have to wait until Ubuntu version N opens for development.

Ken Phillis Jr (kphillisjr) wrote :

I didn't realize that the ubuntu-dev-tools would help with pulling the source.... however i did the rebuild attempt using this command to get the source:

pull-lp-source libva

Cosme Domínguez (cosme) on 2010-08-23
summary: - please backport VLC 1.1.0
+ [test-pkg-a] please backport VLC 1.1.0
Cosme Domínguez (cosme) on 2010-08-24
summary: - [test-pkg-a] please backport VLC 1.1.0
+ [test-pkg-a] Please backport VLC 1.1.3

I can't personally test the backport. I'm running Ubuntu 10.04 (amd-64) and the repository only contains 32-bit packages which will not install.

also, the libva1.0.1.3~lucid1 causes failure on some programs because it is missing the glx libva driver.
Missing header: va/va_glx.h

Also, this will not allow certain programs like Xbmc (latest Subversion) to compile because of the missing header and driver.

Benjamin Drung (bdrung) wrote :

I am against the backport of ffmpeg v0.6. It will break the version of audacity in lucid. The backport of FFmpeg can cause too many issues. Instead vlc should be adjusted to build with the FFmpeg version of lucid.

Attached a patch that will work on lucid. There is only one issue to resolve: Check if the package works with libmodplug-dev from lucid.

bojo42 (bojo42) wrote :

just stumple over this and in the course of maintaining my VLC backport PPA i can confirm Benjamin's patch will work as it's near identical to my changes. also haven't tested the modplug stuff, but atleast it's compiling.

in case anyone likes to test my "clean" backport of VLC:
https://launchpad.net/~bojo42/+archive/vlc

Benjamin Drung (bdrung) wrote :

Why do you use "dh_install --list-missing"? Instead the debian/*.install should be fixed.

bojo42 (bojo42) wrote :

you're right i didn't really dig into the issue, so "dh_install --list-missing" was a lazy fix. but the problem is specific to the PPA builder, as the vlc-data files doesn't get packaged at amd64 (and that's okay, as it's any architecture) and the build logs for maverick are alright. and btw i don't know what to fix in vlc-data.install as the problem is rather somewhere else.

here are the build logs if you like to take a look:
http://launchpadlibrarian.net/55234059/buildlog_ubuntu-lucid-amd64.vlc_1.1.4-1ubuntu1~bojo1~lucid1_FULLYBUILT.txt.gz
http://launchpadlibrarian.net/55226420/buildlog_ubuntu-lucid-i386.vlc_1.1.4-1ubuntu1~bojo1~lucid1_FULLYBUILT.txt.gz

but after all this change shouldn't necessary for an "official" backport build.

Benjamin Drung (bdrung) wrote :

Ok, than your debdiff is alright. Let's get this as backport.

Benjamin Drung (bdrung) on 2010-09-27
summary: - [test-pkg-a] Please backport VLC 1.1.3
+ [test-pkg-a] Please backport VLC 1.1.4-1ubuntu1
Ken Phillis Jr (kphillisjr) wrote :

I gave VLC 1.1.4-1ubuntu1 in the bojo42's ppa a try, and it's working fairly well on the amd64 version of the system.

Manveru (manveru) wrote :

Prevu fails on VLC 1.1.4-1ubuntu1 on Lucid amd64.

The following packages have unmet dependencies:
  pbuilder-satisfydepends-dummy: Depends: libavcodec-dev (>= 4:0.6) but it is not installable
                                 Depends: libavformat-dev (>= 4:0.6) but it is not installable
                                 Depends: libmodplug-dev (>= 1:0.8.8.1) but it is not installable
                                 Depends: libpostproc-dev (>= 4:0.6) but it is not installable
                                 Depends: libswscale-dev (>= 4:0.6) but it is not installable
                                 Depends: libva-dev which is a virtual package.

Benjamin Drung (bdrung) wrote :

As previous mentioned, source changes are required. You have to use the attached patch for backporting the package to lucid.

Miklos Juhasz (mjuhasz) wrote :

I also gave the VLC backport from bojo42's ppa a try, and it's working well on my system. It would be nice to see it as an official backport, especially because the mkv support is much better in this version than in the Lucid default one.

description: updated
Kangarooo Jānis (kangarooo) wrote :

How it going? What needs to be done next to put it on 10.04 LTS ? Can it be still put on 10.04 LTS after for example 1y when LTS is out?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers