Please backport 2.6.34 kernel

Bug #589678 reported by papukaija on 2010-06-04
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Lucid Backports
Undecided
Unassigned

Bug Description

The 2.6.34 kernel is available in Maverick.. Please backport it. Currently maverick has linux 2.6.34-5.12

Elliot Murphy (statik) wrote :

Today I found out that the ubuntu kernel ppa has newer maverick kernels built for lucid. You can see here: https://edge.launchpad.net/~kernel-ppa/+archive/ppa/+packages , look at the linux-meta-lts-backport-maverick package.

papukaija (papukaija) wrote :

Thanks. But does this ppa use Ubuntu specific patches and drivers or is it like the mainline kernel ppa?

papukaija (papukaija) wrote :

Unfortunately the linux-meta-lts-backport-maverick package is not shown in synaptic.

Montblanc (montblanc) wrote :

Backporting the 2.6.34 kernel should have high priority, because many bugs (such as bug #585765 and bug #591532 ) are solved by just upgrading the kernel. Also, you should think about the people who can't upgrade to Lucid because of that bugs, so please consider a 10.04.1 release with 2.6.34 kernel.

Changed in lucid-backports:
status: New → Confirmed
papukaija (papukaija) wrote :

@Montblanc: Lucis is a LTS release, so I doubt if its default kernel can be changed to 2.6.34,but yes that kernel needs to be backported.

@devs: Why is linux-meta-lts-backport-maverick missing from synaptic?

papukaija,
Obviously I know that, but would you call Lucid a "stable" release
with that faulty kernel?

2010/6/15 papukaija <email address hidden>:
> @Montblanc: Lucis is a LTS release, so I doubt if its default kernel can
> be changed to 2.6.34,but yes that kernel needs to be backported.
>
> @devs: Why is linux-meta-lts-backport-maverick missing from synaptic?
>
> --
> Please backport 2.6.34 kernel
> https://bugs.launchpad.net/bugs/589678
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Nandan Vaidya (gotunandan) wrote :

I guess this is applicable here

https://wiki.ubuntu.com/KernelTeam/Specs/KernelMaverickNewKernelOnLTS
AND
https://blueprints.launchpad.net/ubuntu/+spec/kernel-lucid-new-kernel-on-lts

So it seems that once Maverick's kernel is frozen and released, it should be backported to Lucid then.
At least that is what I understood !

papukaija (papukaija) wrote :

@Montblanc: True, but the problem comes from kernel.org's strange way to keep several stable releases while bug fixes go just to the latest kernel.

Montblanc (montblanc) wrote :

Ok, so Maverick kernels are in ppa:kernel-ppa (linux-maverick
package). I guess I'm going to try a fresh install from Lucid LiveCD
hoping that faulty kernel won't harm my system, then upgrade to
maverick kernel. I hope everything goes fine. Should we mark this bug
as Fix Released or should we keep waiting for that packages to be
tagged in lucid-proposed?

2010/6/16 papukaija <email address hidden>:
> @Montblanc: True, but the problem comes from kernel.org's strange way to
> keep several stable releases while bug fixes go just to the latest
> kernel.
>
> --
> Please backport 2.6.34 kernel
> https://bugs.launchpad.net/bugs/589678
> You received this bug notification because you are a direct subscriber
> of the bug.
>

papukaija (papukaija) wrote :

No, this bug should be kept open as the 2.6.34 kernel is not backported to licud-backports. Btw, the linux-maverick will install you a rc version of the 2.6.35 kernel. And please stop including my email address in your comments (fortunately fixing bug 111147 will prevent that).

Montblanc (montblanc) wrote :

In that case I'll just tell apt to install a previous version from the 2.6.34 branch.
(By the way, if you logout you won't see your email address.)

Cheers

Scott Kitterman (kitterman) wrote :

As part of the backports project, we don't backport kernels. I know the kernel team is looking into kernel updates for Lucid, but questions should be directed to the Ubuntu Kernel team and not the Backports team.

Changed in lucid-backports:
status: Confirmed → Won't Fix
David Clayton (dcstar) wrote :

FYI I asked the kernel team mailing list and a TRIM capable kernel is planned to be available for 10.04 once 10.10 is officially released (this was planned quite a few months ago).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints