Lubuntu Software Center

lubuntu-software-center crashed with TypeError in refresh_app_basket(): bad operand type for unary -: 'str'

Reported by Azyl on 2012-03-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Lubuntu Software Center
Medium
Julien Lavergne
lubuntu-software-center (Ubuntu)
Medium
Julien Lavergne

Bug Description

i was trying to install a few aplications ubuntu restricted extra gimp libre office, after adding them to the download basket i clicked download basket

if there is anything else that will help please let me know.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: lubuntu-software-center 0.0.4-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Sun Mar 11 10:36:27 2012
ExecutablePath: /usr/bin/lubuntu-software-center
InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Beta amd64 (20120301.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: python /usr/bin/lubuntu-software-center
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/lubuntu-software-center']
SourcePackage: lubuntu-software-center
Title: lubuntu-software-center crashed with TypeError in refresh_app_basket(): bad operand type for unary -: 'str'
UpgradeStatus: Upgraded to precise on 2012-03-11 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Azyl (dj-azyl) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-software-center (Ubuntu):
status: New → Confirmed
Stefan (stefanp) wrote :

Reproducible: select the game 'Pingus' from the Lubuntu Software Center and click the 'Apps Basket' button:

get => get
get => basket
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/LSC/widgets/pages.py", line 69, in change_section
    self.basket_function()
  File "/usr/lib/python2.7/dist-packages/LSC/main.py", line 422, in refresh_app_basket
    self.ui.apps_basket.model.append([" "*4+item+_(" (requested by ")+items+")", _("unknown"), -("unknown"), _("unknown")])
TypeError: bad operand type for unary -: 'str'

Carlos Carreras (carlosmaxo7) wrote :

I had this bug after add to apps basket a few games: Glchess, solitari, tetris clone. When I was trying to install. Lubuntu 12.04

Julien Lavergne (gilir) wrote :

Thanks for your bug report.
Confirmed, there is a typo on line 422 of main.py, it should be always _("unknown"), not -("unknown")

Changed in lubuntu-software-center (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Julien Lavergne (gilir)
Julien Lavergne (gilir) on 2012-03-22
Changed in lubuntu-software-center:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-software-center - 0.0.5~bzr135-0ubuntu1

---------------
lubuntu-software-center (0.0.5~bzr135-0ubuntu1) precise; urgency=low

  * New upstream snapshot, including only bug fixes and translations updates:
   - Fix crashed with TypeError in __init__() (LP: #959867)
   - Fix crashed with KeyError in __main__ (LP: #951930)
   - Fix crashed with TypeError in refresh_app_basket() (LP: #952070)
   - Fix crashed with NoOptionError in get() (LP: #961418)
   - Fix 'gtkwidgets' is not defined (LP: #946445)
   - Fix encoding problems (LP: #942016)
  * debian/patches:
   - 90_add_ppc_support.patch: Drop, merged upstream.
   - 91_choosed_category_fix.patch: Drop, merged upstream.
   - 92_local_tmp_variable.patch: Drop, merged upstream.
 -- Julien Lavergne <email address hidden> Fri, 30 Mar 2012 00:33:49 +0200

Changed in lubuntu-software-center (Ubuntu):
status: In Progress → Fix Released
Changed in lubuntu-software-center:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers