Update themes for GTK 3.20

Bug #1597526 reported by Jeremy Bicha on 2016-06-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Lubuntu Artwork
High
Unassigned
lubuntu-artwork (Ubuntu)
High
Julien Lavergne

Bug Description

GTK 3.20 was released in March and made substantial changes to theming. It would be great if Lubuntu's themes were ready for it. Ideally, Lubuntu will be ready for GTK 3.20 for Ubuntu 16.10. See bug 1576576.

See the Ubuntu's Desktop's PPA for yakkety:
https://launchpad.net/~ubuntu-desktop/+archive/ubuntu/gtk320

https://lists.ubuntu.com/archives/ubuntu-desktop/2016-June/004805.html

Ubuntu GNOME offers a GNOME3 Staging PPA if you want to test the rest of GNOME 3.20. Since the yakkety series already has GTK 3.21, you may want to just use the xenial series of this PPA.

https://launchpad.net/~gnome3-team/+archive/ubuntu/gnome3-staging

Some resources for the theme conversion:
https://github.com/shimmerproject/Greybird/issues/120#issuecomment-224121206

Some themes in the archives that work (mostly) with GTK 3.20:

- arc-theme
- blackbird-gtk-theme
- breeze-gtk ( gtk3-engines-breeze ) (from Debian)
- greybird-gtk-theme
- mate-themes (from Debian)
- numix-gtk-theme from
https://anonscm.debian.org/git/pkg-mate/numix-icon-theme.git/

- ubuntu-themes ( light-themes ) from
https://code.launchpad.net/~laney/ubuntu-themes/gtk320 or
https://launchpad.net/~ubuntu-desktop/+archive/ubuntu/gtk320

- and of course Adwaita
https://git.gnome.org/browse/gtk+/tree/gtk/theme/Adwaita

Jeremy Bicha (jbicha) on 2016-06-29
tags: added: gtk320
Jeremy Bicha (jbicha) on 2016-07-25
Changed in lubuntu-artwork (Ubuntu):
importance: Undecided → High
Jeremy Bicha (jbicha) on 2016-07-28
description: updated
Redwolf (viking.redwolf) wrote :

Yes, since Light Themes have updated already, Lubuntu theme is getting the new GTK3 updates too.

Changed in lubuntu-artwork (Ubuntu):
assignee: nobody → Rafael Laguna (rafaellaguna)
status: New → In Progress
Jeremy Bicha (jbicha) wrote :

Rafael, I believe ~flexiondotorg has updated ubuntu-mate-themes (in ubuntu-mate-artwork) for GTK 3.20 since ubuntu-mate-themes are closely related to light-themes. I don't know if he's posted his work anywhere yet.

Please discuss your status with ~laney since he is planning to upload GTK 3.20 soon. See also this thread: https://lists.ubuntu.com/archives/ubuntu-desktop/2016-July/004816.html

Redwolf (viking.redwolf) wrote :

Yes, I will, as Lubuntu Box uses Radiance code too. Thanks so much, Jeremy.

Redwolf (viking.redwolf) wrote :

Re-merged code from 14.04+16.10.20160720.laney1-0ubuntu1

Changed in lubuntu-artwork (Ubuntu):
status: In Progress → Fix Committed
Jeremy Bicha (jbicha) wrote :

Rafael, did you see Laney's new post yesterday?

https://lists.ubuntu.com/archives/ubuntu-desktop/2016-July/004817.html

Redwolf (viking.redwolf) wrote :

Yup. It seems Ubiquity gets buggy, but if they don't solve it, we won't, and we use the same app. Everybody has their tasks. Anyway, we have to upgrade to match 3.20 libs.

Julien Lavergne (gilir) wrote :

Thanks, I tested the theme with 3.20, it's working. However, it doesn't work with 3.18, so I'm going to put a libgtk-3-0 (>= 3.20) in the depends to block the theme in -proposed until 3.20 is out.

Changed in lubuntu-artwork:
status: New → Fix Committed
importance: Undecided → High
Changed in lubuntu-artwork (Ubuntu):
assignee: Rafael Laguna (rafaellaguna) → Julien Lavergne (gilir)
status: Fix Committed → In Progress
Jeremy Bicha (jbicha) wrote :

There's several gtk themes that support GTK 3.20 but not GTK 3.18 that don't depend on or break GTK3.

I'm not saying it's wrong to do so; I'm just saying that other themes don't bother. See also https://bugs.debian.org/823714

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.64

---------------
lubuntu-artwork (0.64) yakkety; urgency=medium

  * src/usr/share/themes/Lubuntu-default:
   - Update themes for GTK 3.20 (LP: #1597526).
  * src/usr/share/icons:
   - Add new icons from adwaita-icon-theme 3.20.
  * debian/control:
   - Bump depends on libgtk-3-0 to >= 3.20, for the theme update.
   - Update Provide adwaita-icon-theme = 3.20.

 -- Julien Lavergne <email address hidden> Tue, 02 Aug 2016 22:26:18 +0200

Changed in lubuntu-artwork (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.