/usr/share/themes/Lubuntu-default/gtk-2.0/apps/thunar.rc:55: error

Bug #1459988 reported by Kristian Mörling on 2015-05-29
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Lubuntu Artwork
Fix Released
Undecided
Redwolf
lubuntu-artwork (Ubuntu)
Undecided
Unassigned

Bug Description

A couple of weeks ago I reported this bug https://bugs.launchpad.net/ubuntu/+source/lubuntu-artwork/+bug/1452631.

The problem is related to the themes "Lubuntu-dark-panel" and "Lubuntu-default". The other themes Clearlooks, Crux, Industrial, Mist, Raleigh, Redmond and Thinice do not show this error message. We are getting this error message since the themes use the thunar.rc config file, where a style called "thunar-statusbar" has been declared but has not been defined. I guess that this style is supposed to be used by thunar-statusbar.c in the source code for the thunar package (https://github.com/hubx/thunar/blob/a8b226f8eea8aede4e6708170a52a5d48aa69d67/thunar/thunar-statusbar.c). In thunar-statusbar.c we can see that it seems to be using a style named thunar-statusbar-internal. But there's nothing being mentioned about the style thunar-statusbar in the same source file.

Getting rid of this error message is easy. We only have to comment the declaration for the thunar-statusbar style in /usr/share/themes/Lubuntu-default/gtk-2.0/apps/thunar.rc and /usr/share/themes/Lubuntu-dark-panel/gtk-2.0/apps/thunar.rc. I tested thunar after making these modifications and it seems like these changes do not affect the program.

Branch that should fix the highlighted issue:
https://code.launchpad.net/~testingit/lubuntu-artwork/bug_1459988_fix

description: updated
description: updated
description: updated
description: updated
Redwolf (viking.redwolf) wrote :

Workaround already in main branch. Temporary solution until Thunar accepts new GTK3 statusbar widgets.

Changed in lubuntu-artwork:
assignee: nobody → Rafael Laguna (rafaellaguna)
status: New → Fix Committed
Brenku (p-ubuntuone-5) wrote :

I apologize if I sound dense, but I'm relatively new to this stuff. I am likewise having this specific bug. I am unable to follow along with your fix. What do you mean by "We only have to comment the declaration.."

I mean, I can find these files, and know how to edit them. I am just uncertain what needs to be changed from what to what within those 2 files. Could you clarify for us, please?

Also, if something is already in main branch, how come the problem still occurs? Hah.. I may not exactly understand 100% how that all works. Pardon my ignorance.

Kristian Mörling (testingit) wrote :

It's a good question. There's a few more changes than that in the commited fix. Thanks to Rafael Laguna it was fixed. To get an exact overview of the changes made to fix it you can visit http://bazaar.launchpad.net/~lubuntu-art/lubuntu-artwork/quantal/revision/499

As for your second question I'm not sure how it works. But my guess is that the main brainch has not been uploaded to the ubuntu (codename vivid) repository.

$ apt-cache policy lubuntu-artwork-15-04

on Ubuntu vivid gives me

lubuntu-artwork-15-04:
  Installed: (none)
  Candidate: 0.54
  Version table:
     0.54 0
        500 http://se.archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages

However, the latest version, 0.55, can be found in the ubuntu (codename wily) repository (see http://packages.ubuntu.com/search?keywords=lubuntu-artwork&searchon=names&suite=wily&section=all).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-artwork (Ubuntu):
status: New → Confirmed
Julien Lavergne (gilir) wrote :

Looks fix in current Lubuntu. Closing, thanks for the bug report.

Changed in lubuntu-artwork (Ubuntu):
status: Confirmed → Fix Released
Redwolf (viking.redwolf) on 2016-09-25
Changed in lubuntu-artwork:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers