Arguments in ltsp-init-common and/or lts.conf related to sound isn't honored by fat clients. (LTSP-related)

Bug #923923 reported by niplas on 2012-01-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LTSP5
Low
Alkis Georgopoulos

Bug Description

Hi

[Seen in Edubuntu 11.10 LTSP configuration, server lacks soundcard]

It appears that all valid arguments in lts.conf related to sound isn't honored at all by fat clients.
Nor is the defaults of volume settings at 90% in ltsp-init-common in the case of no sound arguments in lts.conf
(also tried a couple of supposedly valid translated channel variable names with no success)

       SOUND
( SOUND_DAEMON : haven't tried all possible configurations with this one)
       VOLUME
       HEADPHONE_VOLUME
       PCM_VOLUME
       CD_VOLUME
       FRONT_VOLUME
       MIC_VOLUME

All settings tested; Y /true /N /False and three different integers between 10 and 90 for each volume
Tested on a variety of machines using the following lts.conf:
(all machines in FAT client mode, all with different chipsets/soundcards)

[default]
  NBD_SWAP=True
  DNS_SERVER=192.168.100.1
  TIMESERVER=192.168.100.1
  SOUND=True
  VOLUME=10
  SPEAKER_VOLUME=10
  PCM_VOLUME=10
  CD_VOLUME=10
  FRONT_VOLUME=10
# MASTER_MONO_VOLUME=100
# MASTER_MONO_PLAYBACK_SWITCH=on
# MASTER_MONO_PLAYBACK_VOLUME=30
# MONO_VOLUME=30
# MONO_PLAYBACK_VOLUME=30
  X_RAMPERC=95
  X_NUMLOCK=True
  X_BLANKING=600
  LDM_DIRECTX=True
  LDM_LANGUAGE=sv_SE.UTF-8
  SSH_FOLLOW_SYMLINKS=False
  LDM_SESSION="gnome-session --session=gnome-fallback"
  LDM_LIMIT_ONE_SESSION=True
  LDM_THEME=ltsp
# FAT_RAM_THRESHOLD=500 "this setting made 512MB clients go thin" reverting to default (300(?))
# LANG=sv_SE.UTF-8
# LANGUAGE=sv_SE.UTF-8

<*eof*>

/niplas

niplas (niplas) on 2012-01-30
summary: Arguments in ltsp-init-common and/or lts.conf related to sound isn't
- honored by fat clients.
+ honored by fat clients. (LTSP-related)
description: updated
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/923923/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
niplas (niplas) on 2012-01-30
description: updated
affects: ubuntu → ltsp (Ubuntu)
niplas (niplas) on 2012-02-01
description: updated
no longer affects: ltsp (Ubuntu)
Alkis Georgopoulos (alkisg) wrote :
Changed in ltsp:
assignee: nobody → Alkis Georgopoulos (alkisg)
importance: Undecided → Low
status: New → Fix Committed
Alkis Georgopoulos (alkisg) wrote :

Fix released in LTSP 5.3.2.

Changed in ltsp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions