LDM Login window showing resize

Bug #816150 reported by Montana Arble on 2011-07-25
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LTSP
Medium
Jonathan Carter

Bug Description

Description: Ubuntu 11.04
Release: 11.04

ldm-2:2.2.2~bzr1383-0ubuntu1~ppa1~really-2.2.1

There are two window resize icons visible on the LDM login screen. The first one is just below and to the right of the username box. The other is in the lower right hand corner of the screen.

These resize icons are visible regardless of theme or resolution size.

If I double click on the resize icon in the lower right corner the LDM session will restart.

A screenshot has been attached for your reference.

Montana Arble (montana-arble) wrote :
Changed in ldm (Ubuntu):
assignee: nobody → Jonathan Carter (jonathan)
Changed in ldm (Ubuntu):
status: New → Confirmed
Changed in ldm (Ubuntu):
importance: Undecided → Medium
tags: added: iso-testing
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Changed in ltsp:
assignee: nobody → Jonathan Carter (jonathan)
importance: Undecided → Medium
status: New → Confirmed
no longer affects: ldm (Ubuntu)
Wim Muskee (wimmuskee) on 2012-02-17
tags: added: ldm
Jonathan Carter (jonathan) wrote :

I just fixed this in the edubuntu, kubuntu, ubuntu and xubuntu LDM themes by adding this to the greeter-gtkrc files:

"""
# This style removes the ugly resize handles that we don't want on our
# transparent windows
style "remove-handles"
{
  GtkWindow::resize-grip-height = 0
  GtkWindow::resize-grip-width = 0
}

# Apply the style that removes the gtk resize handles
class "GtkWidget" style "remove-handles"
"""

For some reason it doesn't seem to work on the default LTSP theme, but it does on the others. If I copy the entire gtkrc files from one of the other themes, it works. I need to figure out what in the default theme causes the handlebars to remain. Perhaps it's time to update the default theme anyway. I'm taking it up with upstream.

Alkis Georgopoulos (alkisg) wrote :

I'm reusing this bug report for a similar issue which might be caused by the same source...
Sometimes after I enter my username/password, the "box" that contains the ubuntu logo and the username entry box is moved to the left, see the attached screenshot.

Changed in ltsp:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers