Linux Terminal Server Project

ltsp-common-functions: Dereference asterisk in find_opts doesn't work for me

Reported by Horst Prote on 2011-04-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LTSP
Undecided
Unassigned

Bug Description

This is for net-misc/ltsp-client-5.2.6 under gentoo linux
(see also https://bugs.gentoo.org/show_bug.cgi?id=177580#c150):

I have some ThinClients that need
        CONFIGURE_X = Y
        X_MODE_0 = 1600x1200
in lts.conf to start X with the correct resolution.

But after updating ltsp-client:
  [ebuild U ] net-misc/ltsp-client-5.2.6 [5.2.5]
they came up with 800x600. Debugging the startup scripts I finally found that
the XS* scripts (and especially XS90-assembleXorgConf) in
/usr/share/ltsp/screen-session.d/ were not sourced by this code in
/usr/share/ltsp/screen-x-common:
# Run files prefixed with XS* in /usr/share/ltsp/screen-session.d/
if [ -d "/usr/share/ltsp/screen-session.d/" ]; then
    for script in $(run_parts_list /usr/share/ltsp/screen-session.d/ XS); do
        . $script
    done
fi

This again was caused by the find command in run_parts_list() of
/usr/share/ltsp/ltsp-common-functions:
     find -L "$1" -mindepth 1 -maxdepth 1 -type f $find_opts | ...
not listing the XS* scripts. I had to change the definition of find_opts from
     find_opts="-name $2\*"
to
     find_opts="-name $2*"
to fix this.

So unlike the commit comment of revision 1802
(http://bazaar.launchpad.net/~ltsp-upstream/ltsp/ltsp-trunk/revision/1802)
which says "Dereference asterisk in find_opts. Otherwise, this fails
sometimes." for me it _always_ fails _with_ the asterisk in find_opts.

Alkis Georgopoulos (alkisg) wrote :

2 months later there was another commit, 1808, which changed that part of the code to solve the problem you're reporting.
Does commit 1808 work for you?

http://bazaar.launchpad.net/~ltsp-upstream/ltsp/ltsp-trunk/revision/1808

Changed in ltsp:
status: New → Incomplete
Horst Prote (prote) wrote :

As commit 1808 changed "-name $2\*" to "-name $2*", too, I was quite confident when I looked at it and a test proved this true.

Changed in ltsp:
status: Incomplete → Fix Committed
Stéphane Graber (stgraber) wrote :

Marking fix released as commit 1808 is included in release 5.2.7 and higher.

Changed in ltsp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers