Automounted usb drives don't appear on desktop in KDE on ltsp thin clients

Bug #237732 reported by rootchick on 2008-06-05
10
Affects Status Importance Assigned to Milestone
LTSP
Medium
Unassigned

Bug Description

Not sure if this should be reported under ltsp, kde, kubuntu-desktop, or what. This is on Ubuntu 8.04 with kubuntu-desktop and ltsp5 installed. It only occurs on LTSP-based thin clients; when logged into KDE on the server it shows the icon on the desktop.

On a thin client if you log into KDE and plug in a usb drive, it mounts it under /media/username/drivename, but it doesn't create a desktop icon for it. I notice that if you plug one in while under KDE on the server, it just mounts it under /media/disk. If you use Gnome instead on the thin client, it mounts it under /media/username/drivename, but it does show an icon on the desktop.

I wonder if it doesn't have something to do with this bug, since I'm using ldm on the thin client but gdm on the server:
https://bugs.launchpad.net/ubuntu/+source/ldm/+bug/234407

Stéphane Graber (stgraber) wrote :

I can confirm the issue with KDE4 on Intrepid.
The behavior is the same, ltspfs works correctly but KDE doesn't seem to notice a new mount point appearing in /media/<username>/

Other than that, everything seems to work just fine with KDE and LTSP, it'd be great if that last point would be solved too.

Changed in ltsp:
importance: Undecided → Medium
status: New → Triaged
rootchick (cm-ccfls) wrote :

Sounds like it's related to this:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=459369

There's a patch, but it's more of a work-around. Still, it would be nice to have it ported to 8.04. I just haven't figured out how to do it yet.

Oliver Grawert (ogra) wrote :

the mentioned example script is shipped in the ltspfs documentation (the ubuntu and debian packages are identical, so is the fix)

rootchick (cm-ccfls) wrote :

Excellent! I copied the ltspfsmounter script & the example kde-desktop-icons script to my 8.04 server, and it works perfectly. Thanks!

Avinash.Rao (avinash-aol) wrote :

I am facing the same problem with LTSP on Xfce. The USB sticks dont appear on the desktop or even in the places menu. I went through http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=459369 and downloaded the ltspfsmounter.diff file. Should i execute this script in chroot?

How can i make this work?
Thanks
Avinash

Oliver Grawert (ogra) wrote :

you already have /usr/share/doc/ltspfs/examples/kde-desktop-icons installed, quoting from the header of that file:

# to use this hook, install this in /etc/ltspfs/mounter.d/ and mark it as
# executable.

Changed in ltsp:
importance: Undecided → Medium
status: New → Triaged
Changed in ltsp (Ubuntu):
status: Triaged → Invalid
no longer affects: ltsp (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.