Linux Terminal Server Project

Make it possible to create a guest account

Reported by Fred on 2008-03-26
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Shutdown
Undecided
Unassigned
LTSP
Undecided
Unassigned
Xubuntu
New
Undecided
Unassigned
accountsservice
Confirmed
Wishlist
gdm
Fix Released
Undecided
Unassigned
accountsservice (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Brian Murray
kde-workspace (Ubuntu)
Wishlist
Unassigned
Declined for Intrepid by Brian Murray
lxdm (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Brian Murray
sdm (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Brian Murray
slim (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Brian Murray
wdm (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Brian Murray
wing (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Brian Murray
xdm (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Brian Murray

Bug Description

Make a guest account that people can login to, and check their mail, surf web, etc.

Every time the guest account logs out, its purged so the next user who login is a clean fresh account.

This would be great in public terminals, libraries, hotels, lobbys, etc.

Thomas David (nemphis) wrote :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report. Your report looks like a feature request, but filing a bug is not the best way to submit your idea. We have a Specification Process to define, discuss, schedule and implement new features in Ubuntu. Please read the page https://wiki.kubuntu.org/FeatureSpecifications for further details.

Alex Mayorga (alex-mayorga) wrote :
Brian Murray (brian-murray) wrote :

I'm setting this bug's status to Confirmed since it is not assigned to a particular individual working on it at the moment.

This has only been implemented in GDM and not KDM.

Changed in kubuntu-meta:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in ubuntu-meta:
status: Confirmed → Fix Released
Olek Wojnar (olekw) wrote :

I don't think that this is really usable as currently implemented in Intrepid. If I'm there to type in my password then why bother with a guest account?? I understand the security concerns of a passwordless account, but if someone is logging into local GDM and I'm not around the presence of a password won't stop them from doing something bad.

I think that there should be an option to allow guest login from GDM and a locked screen as stated here: http://brainstorm.ubuntu.com/idea/15464/

Olek Wojnar (olekw) wrote :

Changed to new since I don't think the bug has actually been resolved. Should I start a new bug report instead?

Changed in ubuntu-meta:
status: Fix Released → New
Fred (eldmannen+launchpad) wrote :

I am not sure.
I created this before Intrepid was released and had that guest-login thing.
I like the new guest-login thing in Intrepid.

Perhaps it should be possible to create a real account that is a guest account, but not enabled by default.

Kangarooo Jānis (kangarooo) wrote :

Xubuntu could also have guest account.. ?

Kangarooo Jānis (kangarooo) wrote :

Ubuntu devs maybe wanna hear of it in GDM as it would be much much more simple?
Xfce maybe wont do this since its Ubuntu specific feature.
In Ubuntu there is button Guest. And it can be switched to guest.
Also when user is locked then in log in menu there is button Guest.
In Xubuntu locking user is possible with Adding button Switch User to panel (newbies wont know that) and this Guest account can be made but as i tryd and made it without password i couldnot log in in this myself made Guest account without password thrue log in screen. (Maybe this needs reported as bug also- not possible to log in passwordless accounts without password)
So at least lock user button can be added to xubuntu shutdown menu and in log in menu a button could be made available called Guest.
What your ideas?

Changed in kubuntu-meta (Ubuntu):
status: Confirmed → Won't Fix
affects: kubuntu-meta (Ubuntu) → kdebase (Ubuntu)
Changed in kdebase (Ubuntu):
status: Won't Fix → New
affects: kdebase (Ubuntu) → kdebase-workspace (Ubuntu)
Phillip Susi (psusi) wrote :

Not a bug in the ubuntu-meta.

Changed in ubuntu-meta (Ubuntu):
status: New → Invalid
Phillip Susi (psusi) wrote :

This has been implemented according to the specification.

Changed in gnome-shutdown:
status: New → Fix Released
Changed in gdm:
status: New → Fix Released
Fred (eldmannen+launchpad) wrote :

Philip Susi,
In what version was it implemented in?

If I am logged into my account, I can switch to a guest account, but I can not login directly from GDM to a guest account.

tags: added: account guest

It would be handy to be able to create temporary accounts using accounts service, useful for things like guest logins from a display manager.

LightDM currently does this (with code modified from an Ubuntu patch to GDM) [1] [2]. The behaviour is basically:

1. Something requests a guest account
2. A new account is created with a random username guest-XXXXXX
3. Some OS dependant code is run to lock the account down
4. The username is returned
5. The account can be deleted using the username

Are there any plans for this in accounts service? If not, I'll start working on a patch.

[1] http://bazaar.launchpad.net/~lightdm-team/lightdm/trunk/view/head:/src/guest-account.c
[2] http://bazaar.launchpad.net/~ubuntu-desktop/lightdm/ubuntu/view/head:/debian/guest-account

affects: kdebase-workspace (Ubuntu) → kde-workspace (Ubuntu)

Hey Robert,

if you want to work on something like this, that would be great.
Some things to consider:

- it is probably a good idea to have an IsGuestAccount? method on the user object, so we can eg. do the right thing in the user panel

- should it be possible to turn a guest account into a 'real' account ?

- probably needs to be possible to disable guest account creation

The converting a guest account to a real account is an interesting idea - do you expect a user to "try before they buy" by logging in as a guest then opting in to convert to a full account (i.e. keeping their user data). I suspect this could get have some nasty side-effects.

Agree with the other points.

Bryce Harrington (bryce) wrote :

We have no plans to do development work on xdm, so I am going to WONTFIX the xdm task. It's not a bad idea though, but I would suggest approaching upstream about it if you really want it. I suspect it was added to xdm as just a blanket "all dm's should support guest accounts", however xdm is designed to be pretty minimal and more of a working example rather than intended to be a full fledged manager.

Changed in xdm (Ubuntu):
status: New → Won't Fix
Changed in accountsservice:
importance: Unknown → Wishlist
status: Unknown → Confirmed
no longer affects: ldm (Ubuntu)
Harald Sitter (apachelogger) wrote :

Won't happen for KDM seeing as Lightdm provides the feature.

Changed in kde-workspace (Ubuntu):
status: New → Won't Fix
no longer affects: ubuntu-meta (Ubuntu)
Thomas Hotz (thotz) wrote :

Marking as confirmed because it affects several users.

Changed in accountsservice (Ubuntu):
status: New → Confirmed
Thomas Hotz (thotz) on 2013-06-12
Changed in lxdm (Ubuntu):
status: New → Opinion
Changed in wing (Ubuntu):
status: New → Opinion
Changed in wdm (Ubuntu):
status: New → Opinion
Changed in slim (Ubuntu):
status: New → Opinion
Changed in sdm (Ubuntu):
status: New → Opinion
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.