support python3 with libpam-python

Bug #1653149 reported by Vagrant Cascadian on 2016-12-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LTSP
Undecided
Scott Balneaves
pam-python (Debian)
New
Undecided
Unassigned

Bug Description

with ltsp6's pam_sshauth.py module, we use libpam-python, which requires python2. Since python2 is deprecated and due to EOL in 2020, we should get libpam-python upstream to support python3.

Scott Balneaves (sbalneav) wrote :

I've sent an email to the libpam-python author. Will comment as progress on python3 port is undertaken.

Changed in ltsp:
status: New → In Progress
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers