overlayfs missing 'workdir'

Bug #1555168 reported by kdi on 2016-03-09
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
LTSP
Undecided
Unassigned

Bug Description

I have fresh installation of ltsp on Ubuntu 15.10 server
I did ltsp-build-client --arch i386
but I cant boot up the client
it returns overlayfs missing 'workdir'
see more details in screenshoot

kdi (chris-kdi) wrote :
Alkis Georgopoulos (alkisg) wrote :

Again this has been fixed upstream in LTSP for a long time.

The problem is that Ubuntu, from 12.10 to 15.10, has a broken LTSP, and needs someone to do the steps for an SRU in order to get a newer LTSP backported:
https://wiki.ubuntu.com/StableReleaseUpdates

cncook001 (cncook001) wrote :

Using this PPA "sudo add-apt-repository ppa:ts.sch.gr" which gives LTSP version 5.5.5~r2703+p1238+201512091628~ubuntu15.10.1 I get the error mentioned above.

What version of LTSP is needed to resolve this error?

Alkis Georgopoulos (alkisg) wrote :

You need to add that repository in the chroot as well.

cncook001 (cncook001) wrote :

Added that repo to the chroot.

Then exited back to the regular server and rebuilt the image (ltsp-update-image). Now ubuntu client boots.

Thanks

Craig

Same problem on 14.04: worked with kernel 4.2 on the host and 3.13 in the chroot but not with 4.4 on both. Workaround helped, thanks a lot, Alkis, but I really hope this gets more attention and gets fixed very soon.

Alkis Georgopoulos (alkisg) wrote :

> I really hope this gets more attention and gets fixed very soon.

It is already fixed. We (LTSP developers) fixed it years ago.

Now it's a matter of Ubuntu 14.04 users like you to follow the steps for an SRU and get the fix to Ubuntu 14.04:
https://wiki.ubuntu.com/StableReleaseUpdates

If no Ubuntu 14.04 user does those steps, the fix will *never* go to the Ubuntu 14.04 repositories.

But OK no big deal our PPA works fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments