ltsp-cluster SERVER variable is overwritten by ltsp_config file.

Bug #1008618 reported by Marc Gariépy on 2012-06-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LTSP
Undecided
Marc Gariépy
ltsp (Ubuntu)
Undecided
Unassigned
Precise
Medium
Stéphane Graber
Quantal
Undecided
Unassigned

Bug Description

[Impact]
when booting a ltsp-cluster thin client I am unable to get my configuration because the variable SERVER is overwritten by the file /var/cache/ltsp/ltsp_config.

So we need to rename SERVER to CC_SERVER in getltscfg-cluster for it to work properly.

[test case]
configure your chroot to use ltsp-cluster.
run getltscfg-cluster -a

the server that it tryed to contact is the nbd-server
When the script is broken, getltscfg-cluster try to do a wget on the nbd-server instead if the control center.
With the patch, i changed the variable name to CC_SERVER to prevent the sourcing of /var/cache/ltsp/ltsp_config to overwrite the variable.

[regression potential]
None : The variable for the ltsp-cluster is changed to CC_SERVER in the script and configuration for ltps-cluster.

[development fix]
I know this section is deprecated but it's actually relevant in this case ;)
The fix hasn't hit quantal yet because of some massive packaging rework going on with LTSP to try and bring us in sync with Debian. I can guarantee that we will have a new upstream release in quantal that will include this fix. ETA is of a couple of weeks.

the patch can be found here:
http://bazaar.launchpad.net/~ltsp-upstream/ltsp/ltsp-trunk/revision/2303

thanks

Changed in ltsp (Ubuntu Precise):
importance: Undecided → Low
assignee: nobody → Stéphane Graber (stgraber)
status: New → Triaged
Changed in ltsp (Ubuntu Quantal):
status: New → Triaged
Changed in ltsp:
status: New → Fix Committed
assignee: nobody → Marc Gariépy (mgariepy)
Marc Gariépy (mgariepy) on 2012-06-08
description: updated
Changed in ltsp (Ubuntu Precise):
status: Triaged → In Progress
importance: Low → Medium
description: updated
Clint Byrum (clint-fewbar) wrote :

Hi Marc.

Can you clarify the test case a bit? Its really hard to follow.. I'm not sure what to expect in the case where it is broken, or when it is fixed.

Thanks!

Changed in ltsp (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

Hello Marc, or anyone else affected,

Accepted ltsp into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Marc Gariépy (mgariepy) on 2012-06-14
description: updated
Marc Gariépy (mgariepy) wrote :

just tested the new package and it work correctly.

thanks for the upload.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ltsp - 5.3.7-0ubuntu2.1

---------------
ltsp (5.3.7-0ubuntu2.1) precise-proposed; urgency=low

  * Cherry-pick upstream bugfixes:
    - Fix ionice on OpenVZ (r2242) (LP: #1004158)
    - Fix variable name conflict for ltsp-cluster (r2303) (LP: #1008618)
    - Check X_COLOR_DEPTH before overwritting with 16bit (r2316) (LP: #1010198)
 -- Stephane Graber <email address hidden> Fri, 08 Jun 2012 10:55:10 -0400

Changed in ltsp (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in ltsp (Ubuntu Quantal):
status: Triaged → Fix Released
Alkis Georgopoulos (alkisg) wrote :

Fix released in LTSP 5.4.5.

Changed in ltsp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers