Linux Terminal Server Project

Use help2man to generate man pages

Reported by Alkis Georgopoulos on 2012-06-03
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LTSP
Wishlist
Wim Muskee

Bug Description

We're currently maintaining hand-crafted ltsp-* man pages. This is an additional overhead and sometimes the LTSP man pages don't even match the ltsp-tool --help listed options.

help2man (http://www.gnu.org/software/help2man/) can be used to generate them automatically by internally running ltsp-tool --help. It even supports multiple locales, so when we internationalize the tools, we'll automatically get manpages for them as well.
And it can help with ltsp-build-client --extra-help, if we merge that with --help. So at package build time all distro-supported ltsp-build-client options will be listed in its man page (LP: #479423).

We'll need to provide a --version to all of our scripts (using ltsp-common-functions), and maybe an include file for help2man.

Wim Muskee (wimmuskee) on 2012-12-29
Changed in ltsp:
assignee: nobody → Wim Muskee (wimmuskee)
Wim Muskee (wimmuskee) wrote :

Support for autogenerating man pages for all server ltsp tools except ltsp-build-client is ready.

Because the --help of ltsp-build-client sources various scripts, calling that from a build environment won't be possible without some other changes.

We could make ltsp-build-client look for local dirs for instance, or something else...

Wim Muskee (wimmuskee) wrote :

It works for ltsp-build-client as well now. Didn't get around to fixing the gettext entries yet.

Changed in ltsp:
status: Confirmed → In Progress
Wim Muskee (wimmuskee) on 2013-01-10
Changed in ltsp:
status: In Progress → Fix Committed

Cool. Excellent.

On 17 February 2013 12:32, Wim Muskee <email address hidden> wrote:

> ** Also affects: ltsp/ltsp-trunk
> Importance: Wishlist
> Assignee: Wim Muskee (wimmuskee)
> Status: Fix Committed
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (479278).
> https://bugs.launchpad.net/bugs/1008053
>
> Title:
> Use help2man to generate man pages
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ltsp/+bug/1008053/+subscriptions
>

Wim Muskee (wimmuskee) on 2013-02-28
no longer affects: ltsp/ltsp-trunk
Changed in ltsp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers