Weird behaviour with hybrid MBRs

Bug #1749580 reported by Hamish McIntyre-Bhatty
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lshw
New
Undecided
Unassigned

Bug Description

Occurs with: B.02.17 on Ubuntu 16.04, and also other versions (don't know which exactly, but affects every version I've tried this on over the years).

Seems to affect the lshw program on other Linux distros too. I tried reporting on https://www.ezix.org/project/wiki/HardwareLiSter, but it didn't seem to work.

Description:

If there is a hybrid MBR present as well as a GPT, lshw reads the hybrid MBR instead of the GPT. I find this odd, given that lshw can read and understand GPT disks just fine.

Expected to happen:

lshw reports full disk partition information using the GPT, even when there's a hybrid MBR present on the disk.

What actually happens:

lshw reports partial/potentially incorrect information using the hybrid MBR, if one exists, even though there's a GPT will full information as well.

Do I need to provide any further information?

Hamish

affects: lshw (Ubuntu) → lshw
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers