gentoo ebuild deprecation warning

Bug #770301 reported by JD on 2011-04-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LottaNZB
Undecided
Unassigned

Bug Description

Portage is giving this message about the lottanzb ebuild:

 * "/var/lib/layman/lottanzb/net-nntp/lottanzb/lottanzb-0.5.4.ebuild":
 * Deprecation Warning: Usage of distutils.eclass in packages not supporting installation
 * for multiple Python ABIs in EAPI <=2 is deprecated and will be banned on 2011-06-01.
 * The ebuild needs to be fixed. Please report a bug, if it has not been already reported.

Also it would be nice to have ebuilds for newer versions of lottanzb.

Severin Heiniger (severinh) wrote :

Thanks alot for taking the time to report this bug. The mentioned ebuild is not maintained by the LottaNZB development team, but by Lars. A new version of LottaNZB has been released a while ago and updating the ebuild might fix the deprecation problem along the way. I've added Lars to the subscribes of this bug and hope that he's interested in updating the ebuild. This would be greatly appreciated.

Thanks a lot for reporting this bug, JD. This is only a warning, so it is okay to proceed with the install for now. I will fix this as soon as possible, though. I'll also update with an ebuild for the latest version of LottaNZB very soon.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers