lottanzb does not install on ubuntu 10.10

Bug #741629 reported by parislanuit on 2011-03-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LottaNZB
Undecided
Unassigned

Bug Description

At first it worked then i installed Sabnzbd ver 6 and stopped working. I reinstalles version 5.4.1 from ubuntu's 10.10 and can't get lotta to work again: it launches but without the 'inside' of the window. Foll msg :

12:16:24 Démarrage de LottaNZB 0.6...
12:16:24 Une erreur non traitée est survenue :
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/lottanzb/core/environ.py", line 84, in run_with_except_hook
    run_old(*args, **kw)
  File "/usr/lib/pymodules/python2.6/lottanzb/core/component.py", line 466, in run
    self._component_manager.load(self._component_class)
  File "/usr/lib/pymodules/python2.6/lottanzb/core/component.py", line 361, in load
    component = component_class(self)
  File "/usr/lib/pymodules/python2.6/lottanzb/backend/__init__.py", line 106, in __init__
    self.session = self._component_manager.load(session_cls)
  File "/usr/lib/pymodules/python2.6/lottanzb/core/component.py", line 361, in load
    component = component_class(self)
  File "/usr/lib/pymodules/python2.6/lottanzb/backend/sessions/local.py", line 88, in __init__
    self.sabnzbd_config.load()
  File "/usr/lib/pymodules/python2.6/lottanzb/backend/sessions/local.py", line 61, in load
    sabnzbd.LocalConfig.load(self, custom_config_file)
  File "/usr/lib/pymodules/python2.6/lottanzb/config/roots.py", line 226, in load
    self._read(file_object)
  File "/usr/lib/pymodules/python2.6/lottanzb/config/roots.py", line 446, in _read
    self.merge(self._config_obj.dict())
  File "/usr/lib/pymodules/python2.6/lottanzb/config/section.py", line 444, in merge
    self[key].merge(value)
  File "/usr/lib/pymodules/python2.6/lottanzb/config/sabnzbd/__init__.py", line 257, in merge
    _ListConfigSection.merge(self, options)
  File "/usr/lib/pymodules/python2.6/lottanzb/config/section.py", line 442, in merge
    self[key] = value
  File "/usr/lib/pymodules/python2.6/lottanzb/util/gobject_extras.py", line 136, in __setitem__
    self.set_property(key, value)
  File "/usr/lib/pymodules/python2.6/lottanzb/config/section.py", line 268, in set_property
    changed = self.set_unknown_property(key, value)
  File "/usr/lib/pymodules/python2.6/lottanzb/config/sabnzbd/__init__.py", line 177, in set_unknown_property
    value.set_identifier(key)
  File "/usr/lib/pymodules/python2.6/lottanzb/config/sabnzbd/servers.py", line 41, in set_identifier
    self.port = port
  File "/usr/lib/pymodules/python2.6/gtk-2.0/gobject/propertyhelper.py", line 167, in __set__
    instance.set_property(self.name, value)
  File "/usr/lib/pymodules/python2.6/lottanzb/config/section.py", line 266, in set_property
    raise InvalidOptionError(self, key)
InvalidOptionError: La valeur de l'option 'port' de la section 'lottanzb.config.sabnzbd.servers.news.free.fr' est invalide.

---

Brgds
F

Severin Heiniger (severinh) wrote :

Thanks for taking the time to report this bug. It looks like LottaNZB's configuration file (~.config/lottanzb/lottanzb.conf in your home folder) has somehow been corrupted due to the version changes. Removing it should fix the problem. Before doing so, it might be a good idea to copy the content to this bug report as it might help to figure out what went wrong and prevent such problems in the future. If there is any sensitive information (passwords etc.) you should remove them first.

What was the problem that caused you to go back from LottaNZB 0.6 to LottaNZB 0.5.4? And why did you later decide to upgrade to LottaNZB 0.6 again (since the messages you posted are from LottaNZB 0.6)?

Changed in lottanzb:
status: New → Incomplete

Hi Severin, first my lottanzb.conf is as follows:

--------------------------
revision = 5

[backend]
delete_enqueued_nzb_files = False

[backend.sessions]
active = local

[backend.sessions.local]
command = /usr/bin/sabnzbdplus

[backend.sessions.remote]
api_key = ""
host = ""
https = False
password = ""
port = 8080
username = ""

[gui]

[gui.add_file]
last_location = ""

[gui.main]
height = 350
maximized = False
width = 700
x_pos = 162
y_pos = 209

[gui.main.view]
infobar = True
reordering_pane = True
toolbar = True

[gui.messaging]

[gui.messaging.download_import]
last_action = 0

[gui.messaging.postprocessing_priority]
last_action = 0

[plugins]

Then let me explain maybe it will help to understand what went wrong:

I was using lottanzb for a long time and tried sabnzbplus, both worked fine. Then as I have your PPa activated it upgraded to Ver 6 without any problem. But I saw that sabnzb had a ppa and i activated it too. Upon sabnzbd'upgrad (to ver 6.0 beta 2) lotta stopped working... it even said that it couldn't work with this sabnzbd version, that it was not compatible.

I de-activated the sab's ppa and withdrew both sabnzb and lottanzb. I then reinstalled both of them (lotta 6 and sab 5.4.1(Version available in ubuntu's repository...) and damned it still bugged!!! ==> I sent you the bug report...

Hope this will help, seems bug arose when sab's was upgraded to ver 6.0 beta 2 ....

I now withdrew lottanzb.conf, de-installed Lotta with synaptic and re-installed it and it says

----
12:15:18 Démarrage de LottaNZB 0.6...
12:15:19 Impossible de lancer la session: Aucune session n'a été sélectionnée.
---

FYG i am now running sabnzbdplus ver 6.0 beta 4... as i re-activated the ppa...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers