unrar slows down system

Bug #587173 reported by Morten Holmstrup on 2010-05-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LottaNZB
High
Severin Heiniger

Bug Description

hi,

If I let Lottanzb automatically extract packages, my system almost comes to a halt while extracting.

If I do it manually in a terminal with "unrar e [archive]" it takes up a lot less system resources.

Any idea what causes this? (might not be a lottanzb problem, really)

thanks!

Severin Heiniger (severinh) wrote :

Hi robotjox,

post-processing also slows down my machine, but I didn't look into it deeply so far. Another user has asked the same question at ubuntuforums.org. It was suggested to lower the priority of the 'unrar' process using 'nice'. However, it was also suggested that the system becomes unresponsive because it spends most time moving data into and out of the main memory. You might want to take a look at the proposed solutions. I'm highly interested in your findings.

In SABnzbd, which the upcoming version of LottaNZB will be based on, it's possible to set the 'nice' parameters directly in the configuration interface.

Regards,
Severin

[1] http://wwww.ubuntuforums.org/showthread.php?p=8592532

tags: removed: unrar
Changed in lottanzb:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → LottaNZB Development Team (lottanzb)
milestone: none → 0.6
Severin Heiniger (severinh) wrote :

SABnzbd's support for nice and ionice is simply brilliant.

LottaNZB now uses the most conservative values possible for the SABnzbd configurations options 'misc.nice' and 'misc.ionice' that will cause post-processing to have the lowest possible impact on the system's performance.

Making this change allowed me to watch HD material while SAbnzbd performed a download extraction on the very same hard drive. Even though the extraction process didn't take much longer, I noticed no impact on the system's performance.

What is not clear yet how existing SABnzbd users will be able to set the two options using LottaNZB. I'd like to keep the impact on LottaNZB's user interface as small as possible.

Changed in lottanzb:
status: Confirmed → Fix Committed
assignee: LottaNZB Development Team (lottanzb) → Severin Heiniger (lantash)
Changed in lottanzb:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers