Temporary bin/lottanzb.py file not removed when distutilsextra fails in build_i18n.run

Bug #490985 reported by Severin Heiniger on 2009-12-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LottaNZB
Medium
Severin Heiniger
python-distutils-extra
Undecided
Unassigned
python-distutils-extra (Ubuntu)
Undecided
Unassigned

Bug Description

In auto.py, distutilsextra finds extensionless executable scripts which are Python files, and generates a temporary *.py alias, so that they get caught by intltool.

However, if the call to "build_i18n.build_i18n.run(self)" a few lines below fails for some reason, the temporary files will not be removed.

If the user then fixes the problem that caused build_i18n to fail and makes another attempt to install the application, the temporary files will also be installed.

It's probably possible to add a work-around to setup.py, but it would be a better idea to fix this upstream, with a nice "finally" block or something similar.

------------------
Hi, I'm pretty new to linux so if you can, please explain as simple as possible :)
I'm using Opensuse 11.2 x64.

Installed all dependencies, built it, and then when I run it I get this output:

[code]
lottanzb
Traceback (most recent call last):
  File "/usr/local/bin/lottanzb", line 3, in <module>
    from lottanzb.core import App
  File "/usr/local/bin/lottanzb.py", line 3, in <module>
    from lottanzb.core import App
ImportError: No module named core
[/code]

Any idea what I'm doing wrong here?

Thanks in advance!.

Changed in lottanzb:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → LottaNZB Development Team (lottanzb)
status: Confirmed → Triaged
summary: - bin/lottanzb.py not removed when distutils fails in build_i18n.runn
+ bin/lottanzb.py not removed when distutils fails in build_i18n.run

Severin, do you mean the Python project with upstream? It looks like this bug description is incomplete as I can't see anything that indicates this is a Python bug.

I meant distutilsextra (the one we ship with LottaNZB) instead of distutils that ships with Python.

summary: - bin/lottanzb.py not removed when distutils fails in build_i18n.run
+ bin/lottanzb.py not removed when distutilsextra fails in build_i18n.run
description: updated
summary: - bin/lottanzb.py not removed when distutilsextra fails in build_i18n.run
+ Temporary bin/lottanzb.py file not removed when distutilsextra fails in
+ build_i18n.run
description: updated
Changed in lottanzb:
assignee: LottaNZB Development Team (lottanzb) → nobody
description: updated
description: updated
Martin Pitt (pitti) wrote :

Fixed in trunk r155.

Changed in python-distutils-extra:
status: New → Fix Released
Changed in python-distutils-extra (Ubuntu):
status: New → Fix Committed
Changed in lottanzb:
status: Triaged → Fix Committed
milestone: none → 0.5.3
assignee: nobody → Severin Heiniger (lantash)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-distutils-extra - 2.16

---------------
python-distutils-extra (2.16) unstable; urgency=low

  * test/auto.py: Make Apport hook test description consistent to other tests.
  * build_help.py: Fix --help-dir option, thanks to Severin Heiniger for
    spotting this. (LP: #508438)
  * auto.py: Clean up temporary *.py symlinks also if there is an exception in
    between. (LP: #490985)
 -- Martin Pitt <email address hidden> Fri, 29 Jan 2010 18:48:31 +0100

Changed in python-distutils-extra (Ubuntu):
status: Fix Committed → Fix Released
Changed in lottanzb:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions