[LottaNZB 0.5-1] Installer (?) does not invoke 'update-desktop-database'

Bug #425203 reported by Marcel de Vries on 2009-09-06
8
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LottaNZB
Medium
Severin Heiniger

Bug Description

Installer doesn't add LottaNZB correctly to the MIME database. This way firefox doesn't know about LottaNZB. It seems like the installer script "postinst" is missing the following, somewhat critical part.

---
# Automatically added by dh_desktop
if [ "$1" = "configure" ] && which update-desktop-database >/dev/null 2>&1 ; then
 update-desktop-database -q
fi
# End automatically added section
---

The debs for LottaNZB 0.4.1 do include these lines in "postinst".
Workaround:
"sudo -E update-desktop-database" or "sudo su -c "update-desktop-database". I think both would work.

summary: - Installer (?) does not invoke 'update-desktop-database'
+ [LottaNZB 0.5-1] Installer (?) does not invoke 'update-desktop-database'
Severin Heiniger (severinh) wrote :

Hi Marcel de Vries,

I can confirm this issue. Starting with Ubuntu 9.10 (Karmic) this command will not be necessary anymore, but for older versions of Ubuntu, it's still needed of course. The Ubuntu packaged I published was built on my own machine and doesn't contain the "Automatically added by dh_desktop" section, as you've pointed out, although it should. However, the packages built using Launchpad for the LottaNZB PPA all contain the required section for some reason: https://edge.launchpad.net/~lottanzb/+archive/ppa

I guess I'll remove the Ubuntu package I've built on my own and replace it by the three packages built using Launchpad.

The problem is that Gdebi thinks that 0.5-1~jaunty1 is older than 0.5-1. I guess I'll have to reupload it and call it 0.5-2~jaunty1.

Changed in lottanzb:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Severin Heiniger (lantash)
Severin Heiniger (severinh) wrote :

I shouldn't call it 0.5-2 as it will be thought to be newer than the package that will arrive in Debian as 0.5-1. I guess I'll just use the packages I built, if that's okay. People who want to replace the old package by one of the new ones will need to remove the old first.

Severin Heiniger (severinh) wrote :

Building new packages (0.5-1~xxxxx2): https://edge.launchpad.net/~lottanzb/+archive/ppa

Severin Heiniger (severinh) wrote :

Can you check if the problem is fixed now?

Changed in lottanzb:
status: In Progress → Fix Released

Currently I'm not at my desktop. I'll confirm as soon as possible.

Confirmed, installer now invokes "update-desktop-database".

As for Gdebi saying the .deb is older than the installed package, it still does. Don't know if you intend to fix it or not. But I thought I should mention it anyway.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers