Associated helper application does not exsit when trying to open NZB (from Firefox) with LottaNZB Automated Usenet Client.

Bug #384916 reported by Steve Holyer on 2009-06-08
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
LottaNZB
High
Unassigned

Bug Description

Hard to say if this is a problem in LottaNZB, the installer or Firefox, but I just installed LottaNZB.

When I click in Firefox to download an NZB file from the Newzbin site, the download window gives me the option "Open with 'LottaNZB Automated Usenet Client'".

If I select this and press ok, I get the error pop up: "/tmp/Ugly Betty - 3x24 - The Fall Issue.nzb could not be opened, because the associated helper application does not exist. Change the association in your preferences."

If I save the NZB file and then click in Nautilus the NZB is opened with the LottaNZB program.

Severin Heiniger (severinh) wrote :

Hi Steve,

this is a know bug that hasn't been traced down yet despite the fact that it's really annoying. As far as I know, it doesn't even work on my machine at the moment (it did once, when I added the feature ;-)). Another user has already reported it in the 'Answers' section but we could find a solution either.

If this is a problem with LottaNZB, it definitely needs to be fixed. I'll run some more experiment.

For the moment, instead of opening the NZB file in Nautilus, you could also try to double-click on it in the Firefox download manager as soon as the download is complete. Weirdly, this worked on my machine. It does not with Firefox 3.5 Beta_something, which I'm currently using.

Changed in lottanzb:
assignee: nobody → LottaNZB Development Team (lottanzb)
importance: Undecided → High
status: New → Confirmed

Well, I've been having the same problem with P F-files, so I'm not sure it's
LottaNZB relate .

On Jun 8, 2009 10:10 PM, "Severin Heiniger" <email address hidden>
wrote:

Hi Steve,

this is a know bug that hasn't been traced down yet despite the fact
that it's really annoying. As far as I know, it doesn't even work on my
machine at the moment (it did once, when I added the feature ;-)).
Another user has already reported it in the 'Answers' section but we
could find a solution either.

If this is a problem with LottaNZB, it definitely needs to be fixed.
I'll run some more experiment.

For the moment, instead of opening the NZB file in Nautilus, you could
also try to double-click on it in the Firefox download manager as soon
as the download is complete. Weirdly, this worked on my machine. It does
not with Firefox 3.5 Beta_something, which I'm currently using.

** Changed in: lottanzb
  Importance: Undecided => High

** Changed in: lottanzb
      Status: New => Confirmed

** Changed in: lottanzb
    Assignee: (unassigned) => LottaNZB Development Team (lottanzb)

-- Associated helper application does not exsit when trying to open NZB
(from Firefox) with LottaN...
Status in LottaNZB • Automated Usenet Client: Confirmed

Bug description: Hard to say if this is a problem in LottaNZB, the installer
or Firefox, but I just...

Ok I've spend a lot of time on this one. It seems that for some reason newzbin gives .nzb files a "application/force-download" MIME-type. While LottaNZB only registered itself for the "application/x-nzb" MIME-type. I don't know if there's anything else on the www that uses "application/force-download" as MIME-type, but it shouldn't matter because it also check the extension of the file.

Sooo I've been reading all night about stuff, mime-types, Shared MIME-types, GVFS, creating patches and what not. And created a patch using the following guide; https://wiki.ubuntu.com/Bugs/HowToFix. (If you didn't like the way I made the patch please tell me so! I just followed the guide.)

Anyway, nothing special changed. But it does work now! ;-)

Severin Heiniger (severinh) wrote :

This is simply brilliant! It's clear that this bug is one of the most serious ones, but until now, I just didn't have the time to extensively study the whole MIME stuff. I didn't give the patch a try yet but I'll do that soon and I really look forward to seeing this working again! The patch will be part of LottaNZB 0.5.1 if all goes well.

Actually tackling a problem on your own and reading the docs is definitely the best way of learning how things work. Combining your knowledge and your skills with the ones of others in order to build something great really is the spirit of free software.

I guess debdiffs are mostly useful if you want to fix a bug in a Debian/Ubuntu package so that others can give the fix a try in an easy way. Since all users and not only Ubuntu users would profit from this particular bug fix, I'll make the changes directly in LottaNZB's source code.

In other words, if a problem affects all users, the problem should be reported upstream (here :-)). You could branch the code using "bzr lp:lottanzb/0.5" and make all the changes you need to fix the problem. After commiting it using "bzr commit -m '...'" you could create a simple patch using "bzr diff > my.patch". An even better way is to push your local branch (with the fix) to launchpad using "bzr push lp:~your_lp_username/lottanzb/your_fix_for_bug_xxxxxx". You can continue working on your fix and if you think it's ready, you can make a merge proposal.

Again: Thanks alot and congratulations!

I have made a new patch as per the way you told me.

As for;
"An even better way is to push your local branch (with the fix) to launchpad using "bzr push lp:~your_lp_username/lottanzb/your_fix_for_bug_xxxxxx". You can continue working on your fix and if you think it's ready, you can make a merge proposal."

I'll leave that part alone for now. I'm fairly new to this. I mean this is like my second patch I've ever made. ;-)

I do have a question; after grabbing the branch et all and making the changes, I've tried to build the package with "debuild -us -uc -b". But somehow it changes "po/lottanzb.pot". Can you tell me why, or what I'm doing wrong?

Severin Heiniger (severinh) wrote :

I just gave your patch a try and it works perfectly using Firefox 3.0! I'll still need to test Firefox 3.5 on my Ubuntu 9.10 Alpha 5 machine. One just needs to make sure that "update-desktop-database -q" is run after the installation of the package. For some odd reason, this isn't the case if build the package on my own system. The command is executed though if the package is built by Launchpad (using the PPA infrastructure).

Again. Thanks alot for your hard work. You're going to make many LottaNZB users happy. :-)

It's possible to apply the new patch with a simple command. You did everything right. If you'd like me to, I won't commit the patch right away, but guide you through the process of pushing your own branch to Launchpad and making a merge proposal, only if you're interested of course.

1. You've already branched the code and changed it to create the new patch.
2. Commit your change to your local branch: bzr commit -m "Fix MIME type issue for Newzbin downloads. Fixes #384916."
3. bzr whoami "Marcel de Vries"
4. If you don't have an SSH key yet:
4.1. sudo apt-get install openssh-client
4.2. ssh-keygen -t rsa (use the defaults and choose a secure password)
4.3. Your key pair is stored in ~/.ssh/ as id_rsa.pub (public key) and id_rsa (private key)
5. Visit https://launchpad.net/people/+me/+editsshkeys and paste your public key (id_rsa.pub) into the text box.
6. bzr launchpad-login marceldevries
7. bzr push lp:~marceldevries/lottanzb/bug_384916 --remember

Let's hope I didn't forget anything. You branch should show up soon at https://code.launchpad.net/lottanzb and you can propose a merge into lp:lottanzb/0.5.

Of course, steps 3 to 6 only need to be done once. You can commit other changes using "bzr commit ..." and push them using "bzr push".

This process might look a little tiresome, but once you get used to it, it's amazingly powerful and a great way of collaborating. Patch files can get lost or be forgotten, but using a branch, the only difference between your workflow and the one by the core developers of the project is that you don't have write access to the main branch.

Severin Heiniger (severinh) wrote :

As for the po/lottanzb.pot issue: distutilsextra seems to regenerate this file during the build process. I agree that this shouldn't be the case. I'll get in touch with the developer of distutilsextra so that we can fix this.

Thank you for the guide. I'll try it as soon as I get back home which should be around 4 PM.

Changed in lottanzb:
assignee: LottaNZB Development Team (lottanzb) → Marcel de Vries (marceldevries)
status: Confirmed → Fix Committed
milestone: none → 0.5.1

@Sevrin Heiniger:

Thank you for guiding me through the process of fixing the bug. It proves to be pretty usefull. ;-)

You mentioned that the patch didn't work with firefox 3.5 on Ubuntu 9.10, are you sure the installer did invoke "update-desktop-database -q"? As you said building on your machine wouldn't include these sections in "postinst" (Bug #425203).

Anyway, thank you for helping me out getting familiar with launchpad et all! :-)

Steve Holyer (sholyer) wrote :

Thanks Martin for the fix, and Severin for the quick turn around.

Good stuff!

@Severin Heiniger:

I just installed Ubuntu 9.10 with Virtualbox. Build the lottanzb package with my patch included using pbuilder for karmic, and installed it in the VM. The patch does fix it in Ubuntu 9.10 / Firefox 3.5 as well. I haven't changed anything.. so maybe it has to do with your install or something (???).

Forget what I said about "update-desktop-database -q" in post #9, I forgot it was deprecated in 9.10 (FYI, I didn't run "update-desktop-database -q" myself on 9.10. After install my lottanzb package it worked out of the box.)

@Steve Holyer:

If you meant me, it's Marcel. And no problem! :-)

- Build the lottanzb package with my patch included using pbuilder for karmic, and installed it in the VM.

+ Build the lottanzb package with my patch included for karmic using pbuilder, and installed it in the VM.

Grammar...... :-)

Severin Heiniger (severinh) wrote :

I can imagine that old cruft in my Firefox profile is causing the problem. If this means that only my machine is affected, the better! I'll definitely need to reinstall Karmic and start with a clean Firefox profile.

Cool! Thanks for looking into this.

Changed in lottanzb:
status: Fix Committed → Fix Released
Steve Holyer (sholyer) wrote :

Installed from Update Manager, everything works-like a charm. Thanks again MARCEL and Severin.

Looks like this is the case in Karmic again, can someone else please confirm this?

Nevermind, I've installed LottaNZB 0.4.0 instead of 0.5.1! Ashamed ^^

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers