LottaNZB doesn't delete the lock file on shutdown

Bug #268654 reported by Severin Heiniger on 2008-09-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LottaNZB
Medium
Severin Heiniger

Bug Description

When I run LottaNZB as root for the first time, it asks me what mode I want to run in it in. When I run it as a regular user I get the following error:

Traceback (most recent call last):
  File "/usr/bin/lottanzb", line 8, in <module>
    lottanzb.main()
  File "/usr/lib/python2.5/site-packages/lottanzb/lottanzb.py", line 114, in main
    lockAcquired = __lock.acquire()
  File "/usr/lib/python2.5/site-packages/lottanzb/util.py", line 425, in acquire
    raise (self.FileLockAcquisitionError, "Error acquiring lock: %s" % self.fddr())
lottanzb.util.FileLockAcquisitionError

Related branches

Changed in lottanzb:
assignee: nobody → lottanzb
importance: Undecided → Medium
milestone: none → 0.4
status: New → Confirmed
Changed in lottanzb:
status: Confirmed → Triaged
assignee: lottanzb → lantash
Severin Heiniger (severinh) wrote :

This bug has been fixed in revision 534 of the Kiwi branch, which has now been merged into main.

Changed in lottanzb:
status: Triaged → Fix Committed
Changed in lottanzb:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers