LottaNZB doesn't support Python 2.4

Bug #200949 reported by Severin Heiniger on 2008-03-11
4
Affects Status Importance Assigned to Milestone
LottaNZB
Medium
Severin Heiniger

Bug Description

One-line conditional expressions were introduced with Python 2.5.

http://docs.python.org/whatsnew/pep-308.html

Changed in lottanzb:
assignee: nobody → lantash
importance: Undecided → High
milestone: none → 0.2
status: New → Confirmed
Sander Tuit (avirulence) wrote :

(1) Where do we use these?
(2) Do you really think it's necessary to support Python 2.4 with Python 3(000) on it's way?

Severin Heiniger (severinh) wrote :

(1) Twice. See the "launch error" question in the answer section.
(2) Dunno. Python 2.4 was released about three and a half years ago. Didn't know that when I filed this bug. If the incompability issue can be resolved just by removing these two problematic expressions it won't hurt. But otherwise we should advise people to install Python 2.5, agreed.

Sander Tuit (avirulence) wrote :

Agreed.

Changed in lottanzb:
importance: High → Medium
Severin Heiniger (severinh) wrote :

Just for informational purposes: HellaNZB supports Python 2.3 and newer.

http://www.hellanzb.com/trac/hellanzb/browser/trunk/README

Severin Heiniger (severinh) wrote :

At least I'll make the Debian/Ubuntu package depend on Python >= 2.5.0 for the time being.

Changed in lottanzb:
status: Confirmed → Fix Committed
Changed in lottanzb:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions