loggerhead times out annotating large single files (eg sql_parse.cc from mysql-server)

Bug #401412 reported by Christian Hammers on 2009-07-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Unassigned
Launchpad itself
Critical
Unassigned
loggerhead
Critical
Unassigned

Bug Description

Hello

http://bazaar.launchpad.net/~mysql/mysql-server/mysql-5.1/annotate/head%3A/sql/sql_parse.cc

repeatedly gives a:

  Please try again
  Sorry, there was a problem connecting to the Launchpad server.
  Try reloading this page in a minute or two. If the problem persists, let us know in the #launchpad IRC channel on Freenode.
  Thanks for your patience.

I tried a few days and 5 minutes ago with the same error. Other files from the same directory work. Maybe this file is just
too big (230k) or has had too many changes so that some kind of PHP memory_limit or Timeout is hit. Please fix!

bye,

-christian-

Martin Pool (mbp) wrote :

Confirmed today, so not connected to any transient problems with the rewrite map.

Christian, I suspect this file does have too long or complex of a history to be annotated within the cap on request time. Obviously it would be good to: annotate it faster, perhaps give partial data rather than total failure, or at least give a more useful message.

summary: - Internal Server Error when viewing annotated file
+ error annotating large file

Yes, annotating this file seems to take at least 30 seconds, which is longer than the ProxyTimeout we give codebrowse.

It would perhaps be nice to have loggerhead only view files by default, and make the user click another link to get annotations. The current behaviour dates back to knits, when annotation information was almost free.

Changed in launchpad-code:
status: New → Confirmed
importance: Undecided → Medium
Changed in loggerhead:
status: New → Invalid
Michael Hudson-Doyle (mwhudson) wrote :

It's not a bug in loggerhead, per se. If you run loggerhead yourself, you'll get a page, just very slowly.

Jonathan Lange (jml) on 2009-08-26
Changed in launchpad-code:
status: Confirmed → Triaged
Robert Collins (lifeless) wrote :

Running slow is a problem ;)

Changed in loggerhead:
status: Invalid → Triaged
importance: Undecided → High
Changed in launchpad:
importance: Medium → High
summary: - error annotating large file
+ timeout annotating sql_parse.cc from myself-server

I'm upgrading this to critical - it would be triggering a timeout oops in the main website, and we want to make loggerhead a backend service, so this needs to be visible (and fixed)

Changed in launchpad:
importance: High → Medium
Changed in loggerhead:
importance: High → Critical
Changed in launchpad:
importance: Medium → Critical
Martin Pool (mbp) on 2012-02-06
summary: - timeout annotating sql_parse.cc from myself-server
+ loggerhead times out annotating large single files (eg sql_parse.cc from
+ mysql-server)
Changed in bzr:
status: New → Incomplete
status: Incomplete → Confirmed
importance: Undecided → Medium
William Grant (wgrant) on 2012-10-04
tags: added: timeout
William Grant (wgrant) on 2012-10-22
tags: added: codebrowse
Jelmer Vernooij (jelmer) on 2017-11-09
tags: added: check-for-breezy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers