Tracebacks go to console but not log file

Bug #243415 reported by Matt Nordhoff on 2008-06-27
2
Affects Status Importance Assigned to Milestone
loggerhead
Medium
Guillermo Gonzalez
1.6
Undecided
Unassigned

Bug Description

Hi, I'm using Loggerhead's trunk. When Loggerhead tracebacks, the traceback goes to the console, but not the log file (as the summary says..). The log file gets everything else, as far as I can tell, but tracebacks are simply left out.

If it helps, the logging section of my serve-branches.py looks like this:

logging.basicConfig(
    format='%(asctime)s %(levelname)-8s %(name)s: %(message)s',
    level=logging.DEBUG,
)
logfile = logging.FileHandler('/path/to/access.log', 'a')
logfile.setLevel(logging.DEBUG)
formatter = logging.Formatter('%(asctime)s %(levelname)-8s %(name)s: %(message)s')
logfile.setFormatter(formatter)
logging.getLogger('').addHandler(logfile)

Martin Albisetti (beuno) on 2008-06-27
Changed in loggerhead:
importance: Undecided → Medium
status: New → Confirmed
Martin Albisetti (beuno) wrote :

Deferred to 1.7

Changed in loggerhead:
assignee: nobody → guillo.gonzo
Martin Albisetti (beuno) wrote :

Guillermo fixed this a while ago!

Changed in loggerhead:
status: Confirmed → Fix Committed
Martin Albisetti (beuno) on 2008-12-22
Changed in loggerhead:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers