Directory listing doesn't work in root directory

Bug #1262191 reported by Leonardo Donelli on 2013-12-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
loggerhead
Low
Unassigned
loggerhead-breezy
Undecided
Unassigned

Bug Description

Directory/branches listings doesn't work in root directory, it gives error:
"Not found

The resource could not be found"

I feel this is better explained with examples:
My directory structure is:
/srv/bzr/ - root of bazaar projects
/srv/bzr/project-1 - shared repository of project-1
/srv/bzr/project-1/trunk - branch of project-1
/srv/bzr/project-1/feature - another branch of project-1

When launching serve-branches with file://localhost/srv/bzr/project-1/trunk as path
 - http://ip-address:8080 works (i get the branch view with all the revisions etc.

When launching serve-branches with file://localhost/srv/bzr/project-1 as path:
 - http://ip-address:8080 gives 'The resource could not be found'
 - http://ip-address:8080/trunk works: I see the branch view. In the top there is the path: (root)/trunk. Clicking on root takes me to http://ip-address:8080, with the same error as before

When launching serve-branches with file://localhost/srv/bzr as path:
 - http://ip-address:8080 gives 'The resource could not be found'
 - http://ip-address:8080/project-1 works: I see the list of the branches, and clicking on one of them takes me to
 - http://ip-address:8080/project-1/branch which also works.
Clicking on (root) takes as usual to http://ip-address:8080 which doesn't work.

Ubuntu 12.04, tried both the packaged version and a 'fresh' launchpad branch.

summary: - 'Not Found' when using non-branches
+ Directory listing doesn't work in root directory
description: updated
Jelmer Vernooij (jelmer) on 2018-10-20
Changed in loggerhead-breezy:
status: New → Fix Released
Ioana Lasc (ilasc) on 2020-07-28
Changed in loggerhead:
status: New → Triaged
importance: Undecided → Low
Revision history for this message
Colin Watson (cjwatson) wrote :

I've just tested this with current trunk (which has had loggerhead-breezy merged into it) and it seems to work fine now.

One thing to bear in mind while testing this is that if you're changing the root directory around then that breaks the assumptions loggerhead makes when it issues permanent redirects (HTTP 301) to /changes or similar, so for example in Firefox you'll need to take one of the approaches in https://superuser.com/questions/467999/clear-301-redirect-cache-in-firefox to force the browser to forget about the redirect.

Changed in loggerhead:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers