Merged/renamed team remains in directory

Bug #719482 reported by Gavin Panella on 2011-02-15
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LoCo Team Portal
Critical
Michael Hall

Bug Description

The Ubuntu Washington LoCo has two pages:

  http://loco.ubuntu.com/teams/washingtonstate
  http://loco.ubuntu.com/teams/ubuntu-washington

However, the washintonstate team no longer exists in Launchpad. This
has caused at least one user some confusion:

  https://answers.launchpad.net/launchpad/+question/145429

I asked about this here:

  https://answers.launchpad.net/loco-directory/+question/145466

As suggested I followed this up in #ubuntu-locoteams, and had the
following conversation:

{{{
   allenap: Hi, the Ubuntu Washington LoCo has two pages. One of them
            points to a team that no longer exists, so I wondered if
            someone could delete it? More details here:
            https://answers.launchpad.net/loco-
            directory/+question/145466
     daker: allenap, i think czajkowski can do it
   allenap: daker: Tip-top, thank you.
czajkowski: allenap: aye we know
czajkowski: nothing we can do about it though, it's a db issue
czajkowski: nothing the council can do
 cjohnston: czajkowski: cant merge it?
czajkowski: cjohnston: nope seemingly not
 cjohnston: does it give an error?
czajkowski: cjohnston: I don't know. going by what I was told.
czajkowski: cjohnston: ask dholbach
 cjohnston: ook
  dholbach: a db issue?
  dholbach: team admins/owner should be able to merge the teams
  dholbach: there should be a "merge teams" option there
}}}

I had also mentioned it on #ubuntu-us-wa and got a response there too,
later on (slightly edited):

{{{
althara: allenap, it can't be changed. That's why there are two
         washington teams. One has [the] correct launchpad group.
althara: http://loco.ubuntu.com/teams/ubuntu-washington
althara: the loco directory can't handle changes like that
althara: I asked about it when chuck finally got around to changing our
         launchpad team name. They basically said it's not designed to
         update.
}}}

This bug is confusing users so it seems to be worth supporting merged
or renamed teams a little better (just hiding the invalid page would
be enough).

I'm working this week (I'm a Launchpad dev) on making it easier and
more reliable for people to merge teams so this problem is likely to
be a more frequent occurrence.

Related branches

Download full text (4.8 KiB)

Who is the team admin or owner?
On Feb 15, 2011 1:15 PM, "Gavin Panella" <email address hidden>
wrote:
> Public bug reported:
>
> The Ubuntu Washington LoCo has two pages:
>
> http://loco.ubuntu.com/teams/washingtonstate
> http://loco.ubuntu.com/teams/ubuntu-washington
>
> However, the washintonstate team no longer exists in Launchpad. This
> has caused at least one user some confusion:
>
> https://answers.launchpad.net/launchpad/+question/145429
>
> I asked about this here:
>
> https://answers.launchpad.net/loco-directory/+question/145466
>
> As suggested I followed this up in #ubuntu-locoteams, and had the
> following conversation:
>
> {{{
> allenap: Hi, the Ubuntu Washington LoCo has two pages. One of them
> points to a team that no longer exists, so I wondered if
> someone could delete it? More details here:
> https://answers.launchpad.net/loco-
> directory/+question/145466
> daker: allenap, i think czajkowski can do it
> allenap: daker: Tip-top, thank you.
> czajkowski: allenap: aye we know
> czajkowski: nothing we can do about it though, it's a db issue
> czajkowski: nothing the council can do
> cjohnston: czajkowski: cant merge it?
> czajkowski: cjohnston: nope seemingly not
> cjohnston: does it give an error?
> czajkowski: cjohnston: I don't know. going by what I was told.
> czajkowski: cjohnston: ask dholbach
> cjohnston: ook
> dholbach: a db issue?
> dholbach: team admins/owner should be able to merge the teams
> dholbach: there should be a "merge teams" option there
> }}}
>
> I had also mentioned it on #ubuntu-us-wa and got a response there too,
> later on (slightly edited):
>
> {{{
> althara: allenap, it can't be changed. That's why there are two
> washington teams. One has [the] correct launchpad group.
> althara: http://loco.ubuntu.com/teams/ubuntu-washington
> althara: the loco directory can't handle changes like that
> althara: I asked about it when chuck finally got around to changing our
> launchpad team name. They basically said it's not designed to
> update.
> }}}
>
> This bug is confusing users so it seems to be worth supporting merged
> or renamed teams a little better (just hiding the invalid page would
> be enough).
>
> I'm working this week (I'm a Launchpad dev) on making it easier and
> more reliable for people to merge teams so this problem is likely to
> be a more frequent occurrence.
>
> ** Affects: loco-directory
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are subscribed to loco-
> directory.
> https://bugs.launchpad.net/bugs/719482
>
> Title:
> Merged/renamed team remains in directory
>
> Status in LoCo Directory:
> New
>
> Bug description:
> The Ubuntu Washington LoCo has two pages:
>
> http://loco.ubuntu.com/teams/washingtonstate
> http://loco.ubuntu.com/teams/ubuntu-washington
>
> However, the washintonstate team no longer exists in Launchpad. This
> has caused at least one user some confusion:
>
> https://answers.launchpad.net/launchpad/+question/145429
>
> I asked about this here:
>
> https://answers.launchpad.net/loco-directory/+question/145466
>
> As suggested I followed this up in #ubuntu-locoteams, and had the
> following conversation:
>
> {{{
> a...

Read more...

Gavin Panella (allenap) wrote :

> Who is the team admin or owner?

Owner: Chuck West <https://launchpad.net/~chuck-olylug>
Admin: Linda Halligan <https://launchpad.net/~linda-halligan>

Have either of them tried to merge the teams?
On Feb 15, 2011 4:01 PM, "Gavin Panella" <email address hidden>
wrote:
>> Who is the team admin or owner?
>
> Owner: Chuck West <https://launchpad.net/~chuck-olylug>
> Admin: Linda Halligan <https://launchpad.net/~linda-halligan>
>
> --
> You received this bug notification because you are subscribed to loco-
> directory.
> https://bugs.launchpad.net/bugs/719482
>
> Title:
> Merged/renamed team remains in directory
>
> Status in LoCo Directory:
> New
>
> Bug description:
> The Ubuntu Washington LoCo has two pages:
>
> http://loco.ubuntu.com/teams/washingtonstate
> http://loco.ubuntu.com/teams/ubuntu-washington
>
> However, the washintonstate team no longer exists in Launchpad. This
> has caused at least one user some confusion:
>
> https://answers.launchpad.net/launchpad/+question/145429
>
> I asked about this here:
>
> https://answers.launchpad.net/loco-directory/+question/145466
>
> As suggested I followed this up in #ubuntu-locoteams, and had the
> following conversation:
>
> {{{
> allenap: Hi, the Ubuntu Washington LoCo has two pages. One of them
> points to a team that no longer exists, so I wondered if
> someone could delete it? More details here:
> https://answers.launchpad.net/loco-
> directory/+question/145466
> daker: allenap, i think czajkowski can do it
> allenap: daker: Tip-top, thank you.
> czajkowski: allenap: aye we know
> czajkowski: nothing we can do about it though, it's a db issue
> czajkowski: nothing the council can do
> cjohnston: czajkowski: cant merge it?
> czajkowski: cjohnston: nope seemingly not
> cjohnston: does it give an error?
> czajkowski: cjohnston: I don't know. going by what I was told.
> czajkowski: cjohnston: ask dholbach
> cjohnston: ook
> dholbach: a db issue?
> dholbach: team admins/owner should be able to merge the teams
> dholbach: there should be a "merge teams" option there
> }}}
>
> I had also mentioned it on #ubuntu-us-wa and got a response there too,
> later on (slightly edited):
>
> {{{
> althara: allenap, it can't be changed. That's why there are two
> washington teams. One has [the] correct launchpad group.
> althara: http://loco.ubuntu.com/teams/ubuntu-washington
> althara: the loco directory can't handle changes like that
> althara: I asked about it when chuck finally got around to changing our
> launchpad team name. They basically said it's not designed to
> update.
> }}}
>
> This bug is confusing users so it seems to be worth supporting merged
> or renamed teams a little better (just hiding the invalid page would
> be enough).
>
> I'm working this week (I'm a Launchpad dev) on making it easier and
> more reliable for people to merge teams so this problem is likely to
> be a more frequent occurrence.
>
>

Gavin Panella (allenap) wrote :

Yes. The nick "althara" in the last IRC exchange is Linda Halligan I
believe, and the Chuck she referred to is Chuck West (she confirmed
that later in the exchange).

Chris Johnston (cjohnston) wrote :

What is the reason it can't be changed. Merging teams is a feature of LD so
saying it can't be done is not true. Is there an error that is given when
attempting to merge?
On Feb 15, 2011 4:25 PM, "Gavin Panella" <email address hidden>
wrote:
> Yes. The nick "althara" in the last IRC exchange is Linda Halligan I
> believe, and the Chuck she referred to is Chuck West (she confirmed
> that later in the exchange).
>
> --
> You received this bug notification because you are subscribed to loco-
> directory.
> https://bugs.launchpad.net/bugs/719482
>
> Title:
> Merged/renamed team remains in directory
>
> Status in LoCo Directory:
> New
>
> Bug description:
> The Ubuntu Washington LoCo has two pages:
>
> http://loco.ubuntu.com/teams/washingtonstate
> http://loco.ubuntu.com/teams/ubuntu-washington
>
> However, the washintonstate team no longer exists in Launchpad. This
> has caused at least one user some confusion:
>
> https://answers.launchpad.net/launchpad/+question/145429
>
> I asked about this here:
>
> https://answers.launchpad.net/loco-directory/+question/145466
>
> As suggested I followed this up in #ubuntu-locoteams, and had the
> following conversation:
>
> {{{
> allenap: Hi, the Ubuntu Washington LoCo has two pages. One of them
> points to a team that no longer exists, so I wondered if
> someone could delete it? More details here:
> https://answers.launchpad.net/loco-
> directory/+question/145466
> daker: allenap, i think czajkowski can do it
> allenap: daker: Tip-top, thank you.
> czajkowski: allenap: aye we know
> czajkowski: nothing we can do about it though, it's a db issue
> czajkowski: nothing the council can do
> cjohnston: czajkowski: cant merge it?
> czajkowski: cjohnston: nope seemingly not
> cjohnston: does it give an error?
> czajkowski: cjohnston: I don't know. going by what I was told.
> czajkowski: cjohnston: ask dholbach
> cjohnston: ook
> dholbach: a db issue?
> dholbach: team admins/owner should be able to merge the teams
> dholbach: there should be a "merge teams" option there
> }}}
>
> I had also mentioned it on #ubuntu-us-wa and got a response there too,
> later on (slightly edited):
>
> {{{
> althara: allenap, it can't be changed. That's why there are two
> washington teams. One has [the] correct launchpad group.
> althara: http://loco.ubuntu.com/teams/ubuntu-washington
> althara: the loco directory can't handle changes like that
> althara: I asked about it when chuck finally got around to changing our
> launchpad team name. They basically said it's not designed to
> update.
> }}}
>
> This bug is confusing users so it seems to be worth supporting merged
> or renamed teams a little better (just hiding the invalid page would
> be enough).
>
> I'm working this week (I'm a Launchpad dev) on making it easier and
> more reliable for people to merge teams so this problem is likely to
> be a more frequent occurrence.
>
>

Changed in loco-directory:
status: New → Incomplete
Gavin Panella (allenap) wrote :

I'm sorry, I don't know if there was an error, or if the option to
merge is even available to the team admins.

I see you've been chasing things on #ubuntu-us-wa and
#ubuntu-locoteams. With luck someone from the team will comment here.

Michael Hall (mhall119) wrote :

The following error was caught by LD:

Traceback (most recent call last):

  File "/usr/lib/pymodules/python2.6/django/core/handlers/base.py", line 92, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/usr/lib/pymodules/python2.6/django/contrib/auth/decorators.py", line 78, in __call__
    return self.view_func(request, *args, **kwargs)

  File "/srv/loco.ubuntu.com/loco_directory/teams/views.py", line 155, in team_merge
    msgs = merge_teams(old_team, new_team)

  File "/srv/loco.ubuntu.com/loco_directory/teams/utils.py", line 61, in merge_teams
    msgs += [ugettext('Team "%(old_team)" merged with "%(new-team)".' % (old_team.name, new_team.name))]

TypeError: format requires a mapping

<ModPythonRequest
path:/teams/washingtonstate/merge/ubuntu-washington/,
GET:<QueryDict: {}>,
POST:<QueryDict: {}>,
COOKIES:{'__utma': '27501688.1850925296.1295377905.1295377905.1295380326.2',
 '__utmz': '27501688.1295377905.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)',
 'sessionid': '452a8e4eb652b92d700286e2a88716ff'},
META:{'AUTH_TYPE': None,
 'CONTENT_LENGTH': 0,
 'CONTENT_TYPE': None,
 'GATEWAY_INTERFACE': 'CGI/1.1',
 'HTTP_ACCEPT': 'text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8',
 'HTTP_ACCEPT_CHARSET': 'ISO-8859-1,utf-8;q=0.7,*;q=0.7',
 'HTTP_ACCEPT_ENCODING': 'gzip,deflate',
 'HTTP_ACCEPT_LANGUAGE': 'en-us,en;q=0.5',
 'HTTP_CONNECTION': 'keep-alive',
 'HTTP_COOKIE': '__utma=27501688.1850925296.1295377905.1295377905.1295380326.2; __utmz=27501688.1295377905.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); sessionid=452a8e4eb652b92d700286e2a88716ff',
 'HTTP_HOST': 'loco.ubuntu.com',
 'HTTP_KEEP_ALIVE': '115',
 'HTTP_REFERER': 'http://loco.ubuntu.com/teams/washingtonstate/merge',
 'HTTP_USER_AGENT': 'Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)',
 'PATH_INFO': u'/teams/washingtonstate/merge/ubuntu-washington/',
 'PATH_TRANSLATED': None,
 'QUERY_STRING': None,
 'REMOTE_ADDR': '216.254.13.253',
 'REMOTE_HOST': None,
 'REMOTE_IDENT': None,
 'REMOTE_USER': None,
 'REQUEST_METHOD': 'GET',
 'SCRIPT_NAME': '',
 'SERVER_NAME': 'loco.ubuntu.com',
 'SERVER_PORT': 80,
 'SERVER_PROTOCOL': 'HTTP/1.1',
 'SERVER_SOFTWARE': 'mod_python'}>

Michael Hall (mhall119) on 2011-02-16
Changed in loco-directory:
status: Incomplete → Triaged
importance: Undecided → Critical
assignee: nobody → Michael Hall (mhall119)
Changed in loco-directory:
milestone: none → 0.3.2
status: Triaged → Fix Committed
Changed in loco-directory:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers