team search not working

Bug #613132 reported by Michael Hall on 2010-08-03
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LoCo Team Portal
Critical
Michael Hall

Bug Description

After the new per-continent listing change, searching for a team doesn't work, it'll always show the entire list of teams.

Related branches

Changed in loco-directory:
importance: Undecided → High
status: New → Triaged
tags: added: teams
YoBoY (yoboy-leguesh) wrote :

I don't have the skills to correct that bug, but the problem is in teams/views.py and in the team_list.html template.

We are doing our query on the global team_list and pass this to the template, but in the template we don't use it. Instead we use our new continent.related_teams and other lists.

We have to use this team_list to have the search working or filter the other lists before passing them to the template.

Michael Hall (mhall119) on 2010-10-11
Changed in loco-directory:
importance: High → Critical
Michael Hall (mhall119) on 2010-11-20
Changed in loco-directory:
status: Triaged → In Progress
assignee: nobody → Michael Hall (mhall119)
Changed in loco-directory:
milestone: none → 0.2.21
status: In Progress → Fix Committed
Changed in loco-directory:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers