Show map of events

Bug #570613 reported by Daniel Holbach on 2010-04-27
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
LoCo Team Portal
High
Ronnie

Bug Description

Show map of events to make it easier to find "party near you".

Tags: map Edit Tag help

Related branches

Changed in loco-directory:
importance: Undecided → Medium
status: New → Triaged
Daniel Holbach (dholbach) wrote :

(Once bug 524013 is fixed, we should have coordinates of venues easily.)

Changed in loco-directory:
importance: Medium → High
Efrain Valles (effie-jayx) wrote :

I am on it

Changed in loco-directory:
assignee: nobody → Efrain Valles (effie-jayx)
Daniel Holbach (dholbach) wrote :

What's the state of things?

Daniel Holbach (dholbach) wrote :

Bug 524013 is fixed. Is anybody working on this?

Scott Moser (smoser) wrote :

In my opinion, This is a serious bug. Right now, if I'm a new ubuntu community member, and I happen to stumble upon the 10.10 release party page [1], possibly through [2], it is almost impossible to find a release party near me.

Right now, in the United States, it lists:
| United States
| * Maverick Release Party - East Side

"East Side" doesn't mean a whole lot, and as that list grows longer, there will be more generic names that you would have to click through to find where/when the party is.

For the 10.04 release, there was a page http://houseparty.cx (IIRC) that had a google maps view of release parties. That was great for finding a party (but admittedly not all parties were there as it was a pain to use).

--
[1] http://loco.ubuntu.com/events/global/326/detail/
[2] http://loco.ubuntu.com/events/

Laura Czajkowski (czajkowski) wrote :

Actually the team who have created the name for their event " Maverick Release Party - East side" is the Ubuntu-Michigan team. Teams name their events however they chose.

Under USA

United States
Maverick Release Party - East Side
West Michigan Ubuntu 10.10 Release Party

If you click into either of them you get the team details.

The http://houseparty.cx was done by a member of the community and we have since logged this bug in the LD, but unfortunately for this release we may not have it up and running due to other bugs which are more pressing.

Scott Moser (smoser) wrote :

> Actually the team who have created the name for their event " Maverick
> Release Party - East side" is the Ubuntu-Michigan team. Teams name their
> events however they chose.

Right, so the code is not at fault for picking a bad name. The result is the same.

> United States
> Maverick Release Party - East Side
> West Michigan Ubuntu 10.10 Release Party
>
> If you click into either of them you get the team details.

Right again. However, if there are 500 entries there (which I would think is the goal), the user has no other organizational information on which ones might be near them other than this arbitrary string. Suggesting that I click on each of the 500 entries and look at details, and manually determine if this party is close to me, is very much like suggesting that I "go take a hike". The end result will be that I don't find a party.

I'm sorry for sounding like a jerk, I'm just trying to convey the experience. I had this first hand when I was traveling during the 10.04 release, and wanted to find a nearby party. I didn't know the area at all, I wouldn't have been able to determine if a location was nearby or not. But, I could easily have pointed to my location on a map (or even let GPS/geo-locate do it for me). The houseparty.cx site was the only thing that was useful.

I realize you're trying to fix this correctly, and thats great. I realize that a.) this is a feature not a bug b.) people have other things to do with their time.

Overall, I really like the release party stuff. Thanks for the hard work.

Laura Czajkowski (czajkowski) wrote :

Right, so there are a couple of things to think about, Teams name their events, and teams come under regions, so for example using my team here.

I'd look under Europe as well looking under USA, or Asia is going to be of no use to me .
I then look at Ireland and find an event 10.10.10.- Dublin event. That to me is simple and the same goes for most European countries, the difficulty I see where you're coming from is if you're are say travelling to USA.

You'd click down to USA and see a lot of teams, many may not add their team name to an event, we can't force them. What I would then do would be go to the the http://loco.ubuntu.com/events/ page and here I can search by team name, so if I know I'm going to be or around say California then I can see a party has been planned.

Another option, if you were travelling around party time or any time really is to go to the team page and see if they have events planned.

I do take your point regarding the map, it would be nice. but we don't have anyone working on it.. But I don't believe it limits people in finding an event, there are 3 other clear ways to find an event.

thanks for the feedback

Changed in loco-directory:
assignee: Efrain Valles (effie-jayx) → nobody
Adnane Belmadiaf (daker) on 2010-10-15
tags: added: map
removed: maps
Ronnie (ronnie.vd.c) wrote :

Major part of the javascript code is now complete. Markers and Clusters on the map can be clicked.

I need some help on the styling of the popup boxes and the icons of the clusters. Who wants to help?

Changed in loco-directory:
assignee: nobody → Ronnie (ronnie.vd.c)
Ronnie (ronnie.vd.c) on 2010-12-19
Changed in loco-directory:
status: Triaged → In Progress
Nigel Babu (nigelbabu) wrote :

Ronnie, is the style of icons and popup still blocking you? I could help. Poke me on IRC when you're on.

Ronnie (ronnie.vd.c) on 2011-02-18
Changed in loco-directory:
milestone: none → 0.3.1
status: In Progress → Fix Committed
Ronnie (ronnie.vd.c) on 2011-02-22
Changed in loco-directory:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers