Team Owner seems to show ownership, should show leadership - or options

Reported by Chris Johnston on 2010-03-16
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
LoCo Team Portal
Low
Chris Johnston

Bug Description

Currently on a team page (http://loco.ubuntu.com/teams/ubuntu-us-florida) it lists Team Owner.. I feel that this is not an appropriate title and should be changed to team leader. I would venture out to say that the entire team is "technically" the team owner.

Changed in loco-directory:
assignee: nobody → Chris Johnston (chrisjohnston)
Dave Walker (davewalker) wrote :

This is a tricky issue, as many Launchpad team "owners" aren't the actual team leader. I acknowledge that the current terminology isn't ideal, but would propose "Team Admin(s)".

Thomas Bechtold (toabctl) wrote :

ups. i was a bit to fast and merged the branch already. Now the name is "Team Leader". I leave this bug open and we should decide if we want to change again to "Team Admin(s)". I suggest this, too.

Chris Johnston (cjohnston) wrote :

Admins already exists.. Do we want to remove the leader/owner and only do team admins?

Daniel Stone (danielstone) wrote :

There should be the option to choose
Leader
Owner
Coder
Documentor
or whichever the origin insists
A Loco Team=https://wiki.ubuntu.com/LoCoFAQ#Ubuntu%20LoCo%20Teams%20FAQ
A LoCo Team is a Local Community of (in our case) Ubuntu users

Daniel Holbach (dholbach) wrote :

That's why we initially listed launchpad team owners and launchpad team admins as "team contacts". Maybe there's a way to make it clear that this is about LAUNCHPAD team owners/admins?

summary: - Team Owner seems to show ownership, should show leadership
+ Team Owner seems to show ownership, should show leadership - or options
Changed in loco-directory:
status: New → Confirmed
Daniel Holbach (dholbach) wrote :

I don't like the idea of specifically pointing out "leaders". This has caused much debate in the past (lots of people wanted to be "the leader"). "team contact(s)" is much more appropriate in most of the cases. Also is there a lot of teams that don't have a de-facto leader, but a lot of very enthusiastic and well-organised people, who take care of things and the team is happy with that. Why should we require them to name a leader?

As I said in comment #5: the use of "owner" and "admin" is strictly technical in terms of Launchpad-speak.

tags: added: needs-decision
Nathan Handler (nhandler) wrote :

I personally think we should continue to use the terms owner and admin to match what Launchpad currently uses. We can make it clear that this is what the terms are referring to by saying "Launchpad Team Owner" and "Launchpad Team Admin". Changing these terms to anything else would change their actual meaning. For instance, calling both the owner and admins the "Team Contacts" would confuse the meaning of that term. Previously, all LoCo teams were required to have a team contact (not necessarily the leader of the team or the admin on Launchpad) who would take care of any CD requests for the LoCo and served as a point of contact between the LoCo, Canonical, and the Ubuntu community.

Daniel Stone (danielstone) wrote :

The term does not describe the role
According to wikipedia
http://en.wikipedia.org/wiki/Owner
Ownership is the state or fact of exclusive rights and control over property, which may be an object, land/real estate or intellectual property.

tags: added: team-roles
Curtis Hovey (sinzui) wrote :

This is correct from Launchapd's perspective because teams were create for ACL control, not communication. I also think this is insane since every person with nominal English undstands that a team is a group of people bound of a common interest. We can change the presentation in the Web UI to be leader. I do no think this issue can be fully resolved in Launchpad until the ACL system is replaced.

Changed in launchpad-registry:
status: New → Triaged
importance: Undecided → Low
Daniel Holbach (dholbach) wrote :

Regarding the LoCo Directory portion: is everybody happy with "Launchpad Team Owner" and "Launchpad Team Admins" for now?

Does this need an additional kind of "here's help if you don't understand what this means" question mark icon?

Changed in loco-directory:
importance: Undecided → Low
status: Confirmed → Triaged
Chris Johnston (cjohnston) wrote :

IMO for now we should go with Laundhpad Team Admins, and then make a wishlist item to have a Team Contacts list.

Daniel Holbach (dholbach) wrote :

By "Team Contacts list" do you mean teams to specify who of their team are the designated team contacts?

Chris Johnston (cjohnston) wrote :

Yes...

Laura Czajkowski (czajkowski) wrote :

I really do not like seeing the word Team Leader as it implies power. Team owner or Team admin would be prefered. It translates better and I think we should be seeing this across the board as it seems to come up regularly.

Alan Pope ㋛ (popey) wrote :

Teams have leaders, that's why we have a leadership code of conduct.

We should constantly reinforce the view of leadership as a
responsibility not a power. Daniel did that very effectively with the
IRC council changes we worked on earlier this year. I understand the
concern, but ultimately, leadership is a good thing that we should not
be afraid of, we should just work hard to make sure we have effective
leaders.

Laura Czajkowski (czajkowski) wrote :

Right, I just think we need to be clear, what a Team owner is and what a team leader is as there is some confusion with LoCos. So maybe that's something we can address and clarify perhaps. I agree we should encourage people to Lead LoCos effectively

Daniel Holbach (dholbach) wrote :

I think we all agree that some teams have leaders, sometimes they are appointed and the team's constitution gives them certain privileges and responsibilities, sometimes it's the "de facto" leaders that nobody ever appointed, but those who make the decisions because the entire team trusts their judgement and great work.

In the case of the LoCo Directory we can programmatically just get the LP Owner and LP Admins of the team and we do this to make a simple ACL decision.

I don't know if we gain a lot if we allow team members or team admins to identify the "team leaders" among their team in the LoCo Directory UI. While I think it's good to identify and recognise good leaders, the simple distinction in this case opens the doors for those who are "in it for the title and glamour". If it's worth to do that just for the ACL decision the LoCo Directory needs to make, I don't know.

Chris Johnston (cjohnston) wrote :

+1 for showing team contacts

Daniel Stone (danielstone) wrote :

In the LoCo team there may exist several roles
The most fitting for this interface would be contact(s)

On launchpad registration page it would be helpful if:
team role could be available
Currently the Team owner selects an admin
It gives no option to select team contact(s)
In larger territories/states or teams this poses an issue

Jan Claeys (janc) wrote :

Facts:
- currently the "team owner" on launchpad is not necessarily a team leader or the team contact
- same for the admins of the launchpad team
- there is no other way to identify the team contact on LP

What we want/need:
- the loco directory needs to list the team contact(s).
- the loco directory should not show the LP team owner if that person is not the contact

I doubt LP will be changed to allow listed "roles" in a team soon (enough). So I guess what we need is a way to add a team contact (or maybe multiple team contacts if there is more than one) to the locoteam manually inside the loco directory. Useful info about them would be real name, e-mail address & IRC/forum nicknames.

An alternative would be to make it mandatory that team contacts become the "owners" of the LP-team of the loco. Not sure how to do that with teams that have more than 1 contact though? Can LP teams be the owners of other LP teams ?

Curtis Hovey (sinzui) wrote :

I am not certain about the 3 facts. I understand teams want roles, but in the abense of them, launchpad uses the owner as the lead and contact. As I am not a member of ~loco-directory-dev, I see "Contact this team's owner" as the text of the contact link. I can see Daniel is the owner. If you use the Contact this team link for a team you are not a member, you are contacting the person that is listed as the owner. If the listed owner is a team, Launchpad searches the heirarchy for the person who is the owner. For many crucial teams, this person is Mark.

Jan Claeys (janc) wrote :

@Curtis Hovey: I'm talking about the current situation with locoteams, and then those 3 facts are... facts.

Of course we could get closer to how the most of LP seems to work *now*, that's the alternative I talk about, but we would have to decide on that and inform all people involved with a deadline to make all necessary changes. Also, the whole purpose of having multiple contacts is so that all of them get contacted; but maybe that's no issue, as the loco directory could pull all members of a "contacts team" and show their info (or they could use the mailing list feature in LP)?

Changed in loco-directory:
status: Triaged → Fix Committed
milestone: none → 0.2.3
Changed in loco-directory:
status: Fix Committed → Fix Released
Curtis Hovey (sinzui) on 2010-12-03
tags: added: teams
Curtis Hovey (sinzui) wrote :

Launchpad no longer uses the team owner as the team contact. Owners can and do leave the team to delegated responsibility to the admins, or the owner is just absent. Lp now recognises the team admins as the only role that acts as a contact.

The team owner from Lp's perspective is is not a leader. The owner is responsible for chartering the team's purpose. The owner may may also be admin involved in the day-to-day running of the team. The owner can promote others to admin the team. The admins make decisions of membership, manage archives, mailing lists, and subscriptions. I think the team admin role closer to the team leader role than the team owner role is.

Charles Profitt (cprofitt) wrote :

I see some loco teams as operating much differently than what launchpad allows for. Certainly for larger geographic areas there is a need for more than one 'admin' -- ie., being able to add/edit/delete items on loco.ubuntu.com. I also see allowing multiple contacts as a good thing because it helps to avoid the issue of a contact/owner becoming a point of failure for team communications. While we might wish that people did not go "off the grid" it does happen; multiple contacts should increase the likelihood that the team will get communications and be able to respond accordingly.

Curtis Hovey (sinzui) wrote :

@Charles Profitt (cprofitt)
I think Bug #4744 covers this issue "Team admins aren't encouraged to promote other members"

William Grant (wgrant) on 2013-08-12
no longer affects: launchpad
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers