Team Approved/Expire dates don't require time.

Bug #494950 reported by Dave Walker on 2009-12-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LoCo Team Portal
Medium
Unassigned

Bug Description

The approved_date and expires_date are of type DateTimeField which also gives us the following representation:
2010-06-22 13:33:03.308369

I would argue that that time element is irrelevant, and the only important data is the date.

Related branches

Changed in loco-directory:
importance: Undecided → Medium
milestone: none → 0.1.1
status: New → Triaged
Changed in loco-directory:
status: Triaged → Fix Committed
Changed in loco-directory:
status: Fix Committed → Fix Released
Laura Czajkowski (czajkowski) wrote :

This is still an issue and can be seen on http://loco.ubuntu.com/teams/ubuntu-ie

Daniel Holbach (dholbach) wrote :

Reopening, still a problem.

Changed in loco-directory:
milestone: 0.1.1 → none
status: Fix Released → Triaged
Chris Johnston (cjohnston) wrote :

On a local install it seems to be correct. Is it possible that the info in the database includes the times still and they need to be removed from there?

Daniel Holbach (dholbach) wrote :

<dholbach> cjohnston, I think that's a problem in the migrations - it's a missing migration (so it's changed in the model, but not in the database)
<dholbach> cjohnston, it might be fixed in my profile branch (it has one of those migrations which was added automatically)
<cjohnston> Gotcha.. all I know is I can't reproduce it...
<dholbach> go back to a very old version of the code, create a database, run all migrations
<cjohnston> ahh

Changed in loco-directory:
assignee: nobody → Daniel Holbach (dholbach)
status: Triaged → In Progress
Changed in loco-directory:
milestone: none → 0.2.18
status: In Progress → Fix Committed
Changed in loco-directory:
status: Fix Committed → Fix Released
Chris Johnston (cjohnston) wrote :

This bug still isn't fixed.

Changed in loco-directory:
status: Fix Released → Confirmed
milestone: 0.2.18 → none
assignee: Daniel Holbach (dholbach) → nobody
Ronnie (ronnie.vd.c) wrote :

The change happens somewhere in the 0.1 version of LP.

What i did to hopefully fix it:

changes models.py of the head version:
 - DateField to DateTimeField

./manage.py schemamigration --auto teams

Change in the 0013_auto__chg_field_team_approved_date.py:
 - Flipped the lines from the functions: forwards and backwards

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers