translations do not work in form

Bug #400562 reported by Daniel Holbach on 2009-07-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LoCo Team Portal
Medium
Efrain Valles

Bug Description

Can some Django expert please take a look at why translations are not used in the forms yet?

Changed in loco-directory:
importance: Undecided → Medium
milestone: none → 0.1.0
status: New → Triaged
Efrain Valles (effie-jayx) wrote :

I haven't had the chance to try the translations in the LoCo Directory. is the rest of the app translataed at all? is it just the forms?

Changed in loco-directory:
assignee: nobody → Efrain Valles (effie-jayx)
Daniel Holbach (dholbach) wrote :

It's generally translated (German works for me there), it's just the forms where it doesn't seem to work.

Changed in loco-directory:
milestone: 0.1.0 → 0.1.1
Daniel Holbach (dholbach) wrote :

This in any case shouldn't prevent us from "going live".

Efrain Valles (effie-jayx) wrote :

Have we tried translating the verbose_name in the models.py.

The forms come from models directly, so the verbose name indicates the label field for each combo box. I believe this can help. I am not very good at translations, maybe daniel can try this and see

Daniel Holbach (dholbach) wrote :

Hm, I'm not sure what that means - what kind of fix are you suggesting?

Daniel Holbach (dholbach) wrote :

It works for me now. Can anybody confirm?

Changed in loco-directory:
status: Triaged → Incomplete
Daniel Holbach (dholbach) wrote :

We believe this is fixed in 0.1.1 now. If you can still reproduce the problem, please reopen the bug.

Changed in loco-directory:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers