Implement missing functionality to make location-service a trusted helper.

Bug #1219164 reported by Thomas Voß on 2013-08-31
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
location-service
Fix Released
High
Thomas Voß
location-service (Ubuntu)
Critical
Thomas Voß

Bug Description

Address FIXME in code and query the user if an app wants to access the location service:

if (credentials.pid != pid || credentials.uid != uid)
        return Result::granted; // FIXME(tvoss): This should return rejected.

Related branches

Changed in location-service (Ubuntu):
importance: Undecided → Critical
importance: Critical → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in location-service (Ubuntu):
status: New → Confirmed
tags: added: application-confinement
Changed in location-service (Ubuntu Saucy):
status: Confirmed → Won't Fix
Jamie Strandboge (jdstrand) wrote :

Per meeting today, this is needed for RTM.

Changed in location-service (Ubuntu Trusty):
status: Confirmed → Won't Fix
Changed in location-service (Ubuntu Utopic):
status: Confirmed → In Progress
assignee: nobody → Thomas Voß (thomas-voss)
tags: added: rtm14
Changed in location-service:
status: Confirmed → In Progress
Jamie Strandboge (jdstrand) wrote :

Removing old tasks and raising priority to Critical per RTM bug triage procedures (we must deliver this for RTM). Thomas, can you adjust the location service task to be Critical? Thanks!

no longer affects: location-service (Ubuntu Saucy)
no longer affects: location-service (Ubuntu Trusty)
no longer affects: location-service (Ubuntu Utopic)
Changed in location-service (Ubuntu):
importance: High → Critical
Changed in location-service:
status: In Progress → Fix Released
Changed in location-service (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers