LibreOffice "Window" menu is hidden

Reported by Waldir Leoncio on 2011-04-14
568
This bug affects 118 people
Affects Status Importance Assigned to Milestone
LibreOffice Menubar Extension
Undecided
Unassigned
libreoffice (Ubuntu)
High
Unassigned

Bug Description

LibreOffice has 9 menus: File, Edit, View, Insert, Format, Tools, Data, Window and Help. lo-menubar shows every menu entry but Window, rendering important actions such as Split and Freeze inaccessible.

Screenshot: https://bugs.launchpad.net/ubuntu/+source/lo-menubar/+bug/801455/+attachment/2180143/+files/Screenshot.png

WORKAROUND: Tools->Customize you can see the missing Window menu.

Just put the same missing entries under another top-menu (e.g. "Help")

See also bug #902646 ("lo-menubar doesn't work with libreoffice-startcenter").

Martin Fisher (yusuf-martin) wrote :

I have read that some people do not have this problem, but I certainly do.

Martin

Waldir Leoncio (wleoncio) wrote :

Considering #1, marking as "confirmed".

Changed in lo-menubar:
status: New → Confirmed
Martin Fisher (yusuf-martin) wrote :

Some further information: Using LibreOffice 3.3.2 OOO330m19 (Build:202) tag libreoffice-3.3.2.2, Ubuntu package 1:3.3.2-1ubuntu (info from the about menu), if there are no documents open the unity global menu for LibreOffice disappears and appears in the LibreOffice window instead. Open a document and the global menu reappears.

papukaija (papukaija) on 2011-05-15
Changed in lo-menubar (Ubuntu):
status: New → Confirmed
KristerL (draengen) wrote :

A workaround until this bug is fixed:

In LibreOffice, under Tools->Customize you can see the missing Window menu.

Just put the same missing entries under another top-menu (e.g. "Help") and you at least have
a way to reach the commands:

New Window
Close Window
SplitWindow
FreezeWindow

Regards
Krister

Martin Fisher (yusuf-martin) wrote :

Many thanks: incredibly helpful! I have managed to put New Window under the View menu. I can't find the SplitWindow or Freeze Window anywhere though - where are they?

Thanks and regards, Martin

Tom Huber (thhuber) wrote :

split window and freeze window are located in the view menu as well, commands are alphabetically sorted, so scroll down to "f" and "s"; my solution. many thanks to krister from me as well, nice work-around hope that one day "window" will work as well. rgds tom

Alienhunter2010 (acecchin) wrote :

I confirm the bug too.

The window menu disappears also when a document is open.

Using LibreOffice Calc I use so much times Freeze and/or split commands, and it is really annoying!

Nikolay Kolev (kolev) wrote :

Very annoying and it's really pathetic that a small bug makes the whole LibreOffice look sub-par to the unsuspected user!

@Alienhunter2010
@Nikolay

Just dis-install "lo-menubar" if "windows menu" is that much important for you (as it is for me).

You won't have global menubar integration with unity, but this is a small inconvenience in my opinion in comparison to the absence of the windows menu.

papukaija (papukaija) on 2011-09-07
tags: added: metabug
Martin Fisher (yusuf-martin) wrote :

Is this going to be fixed for Ubuntu 11.10? It seems odd that the main software suite, for some, in Ubuntu should be dysfunctional. I have added a comment to a relevant thread in the Oneiric forum (http://ubuntuforums.org/showthread.php?t=1834662)

Saaz Rai (saaz-rai) wrote :

The bug still persists in 10.10 Beta 1.

Saaz Rai (saaz-rai) wrote :

Correction: The bug still persists in 11.10 Beta 1.

Martin Pitt (pitti) on 2011-09-21
tags: added: lo-menubar-p-default
Changed in lo-menubar (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu Precise):
status: New → Confirmed
Changed in libreoffice (Ubuntu):
status: New → Confirmed
Alberto Ruiz (alberto.ruiz) wrote :

Window Menu is hidden on purpose.

The UNO API used to develop the menubar integration did not allow the Window menu to work properly so I'm afraid that until an upstream integration is done (overriding the UNO API and exposing the menu actions/structure/shortcuts from the inside of VLC, the LO toolkit) this won't get fixed.

Alberto Ruiz (alberto.ruiz) wrote :

On the other hand, if we have a rich shell such as Unity, the Window menu becomes a bit useless.

Unity doesn't substitute features like split and freeze, though. :-/

On Tue, Oct 11, 2011 at 11:13 AM, Alberto Ruiz <email address hidden> wrote:

> On the other hand, if we have a rich shell such as Unity, the Window
> menu becomes a bit useless.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/760879
>
> Title:
> "Window" menu is hidden
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/lo-menubar/+bug/760879/+subscriptions
>

Thanks for the tip to uninstall lo-menubar. This solves the window menu problem and the problem that it's impossible to access menus using Alt-F etc., which was also making LibreOffice unworkable for me.

Changed in libreoffice (Ubuntu Precise):
importance: Undecided → High
Changed in lo-menubar (Ubuntu Precise):
status: Confirmed → Triaged
Changed in libreoffice (Ubuntu Precise):
status: Confirmed → Triaged
Augustine Souza (aesouza2008) wrote :

Even with the workaround for the missing "Window", the other problem remains: several keyboard shortcuts don't work if the extension is installed (https://answers.launchpad.net/ubuntu/+question/177501).

Teguh Wibowo (kangtguh) wrote :

Many thanks to KristerL(draengen) ...very helpful!

Thanks and best regards,

Paul Sladen (sladen) on 2012-01-06
description: updated
Changed in libreoffice (Ubuntu Precise):
status: Triaged → Invalid
description: updated
tags: added: natty running-unity
tags: added: i386
no longer affects: libreoffice (Ubuntu)
no longer affects: libreoffice (Ubuntu Precise)
Xavier Guillot (valeryan-24) wrote :

Bug is still present in Precise, with last updates installed.

No "Window" menu in LibreOffice with lo-menubar.

But workaround done by KristerL (comment 4) solves the "split - freeze" problem, thanks !

papukaija (papukaija) on 2012-03-20
tags: added: precise
tags: added: rls-mgr-p-tracking
edyjun75 (edyjun75) wrote :

Not only using lo-menubar cause window menu missing, but it also cause libreoffice crash when we click document preview

this needs https://blueprints.launchpad.net/ubuntu/+spec/desktop-p-libreoffice-lo-menubar-polish which is postponed to quantal, denominating for precise.

no longer affects: lo-menubar (Ubuntu Precise)
giuliano69 (giuliano-lotta) wrote :

under 12.04, I can confirm the Menu item disappearing, and also the preview crash.
Unfortunately, uninstalling the lo-menubar, the HUD does NOT work in LibreOffice.

This should be a great reason to FIX the problem...

:-((

Håvar Nielsen (havar) wrote :

Work around:
Add a keyboard shortcut key:
Tools -> Customize... -> View -> Freeze Window

Le Gluon Du Net (legluondunet) wrote :

Still not fix in Precise?

papukaija (papukaija) wrote :

No, it's not (and won't be until it's fixed in Quantal). Please see https://wiki.ubuntu.com/Bugs/Status for more information. Thanks.

summary: - "Window" menu is hidden
+ LibreOffice "Window" menu is hidden
Sebastien Bacher (seb128) wrote :

the issue is fixed in libreoffice in quantal which has integrated support for unity menus

affects: lo-menubar (Ubuntu) → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
Julien Olivier (julo) wrote :

In Quantal, using gnome-shell, I still don't see libreoffice's menu, as you can see on the attached screenshot. Do I need to install or uninstall any package, or configure something?

Yes, the bug is fixed in libreoffice 1:3.6.2~rc2-0ubuntu3.

Omer Akram (om26er) on 2012-10-12
Changed in lo-menubar:
status: Confirmed → Invalid
John Winterton (jwinterton) wrote :

Affects quantal:
Description: Ubuntu 12.10
Release: 12.10
libreoffice-calc:
  Installed: 1:3.6.2~rc2-0ubuntu3
  Candidate: 1:3.6.2~rc2-0ubuntu3
  Version table:
 *** 1:3.6.2~rc2-0ubuntu3 0
        500 http://ca.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status
Description: Ubuntu 12.10
Release: 12.10
N: Unable to locate package libreoffic-writer
john@john-12-10:~$ bugger libreoffice-writer
Description: Ubuntu 12.10
Release: 12.10
libreoffice-writer:
  Installed: 1:3.6.2~rc2-0ubuntu3
  Candidate: 1:3.6.2~rc2-0ubuntu3
  Version table:
 *** 1:3.6.2~rc2-0ubuntu3 0
        500 http://ca.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status

Most annoying.

johnfrith (johnfrith1) wrote :

I have this problem in 12.04.

Roland (roland-breedveld) wrote :

Why only fixed in 12.10 and not in 12.04 LTS ?
long-time-support version should be more stabe .......

John Winterton (jwinterton) wrote :

Just performed an update to Quantal. This problem is not fixed in LibreOffice-Calc. This can be handled by an experienced user but a naive user would chuck the whole operating system and retreat to Windows. It is more important than this log seems to indicate.

Description: Ubuntu 12.10
Release: 12.10
libreoffice-calc:
  Installed: 1:3.6.2~rc2-0ubuntu3
  Candidate: 1:3.6.2~rc2-0ubuntu3
  Version table:
 *** 1:3.6.2~rc2-0ubuntu3 0
        500 http://ca.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status

The thing I find annoying most of all from a software point of view is that this is a RELEASE CANDIDATE. What is the matter with your qualifty assurance? I am beginning to think that the entire Unity project is a great mistake.

John Winterton (jwinterton) wrote :

Well, to my great surprise, this morning's fix did work after a time. Immediatly after the fix was downloaded and installed by apt, nothing was changed. Half an hour later, all is well.

This is a new idea for me. I have always believed that if you put a fix in a program it has immediate effect.

John Winterton (jwinterton) wrote :

Worse, yet. From my previous comment to now, I no longer have these menus. The problem seems to be intermittent. Computer programs are not supposed to do this. Do you suppose the Unity code needs a total rewrite?

papukaija (papukaija) wrote :

The missing menus (all not just the window) is bug 1064962 and has nothing to do with this bug.

@ John Winterton (comment #35):
Actually, LO 3.6.2 RC2 is the stable release. It is often the case with LO. You can have a look a this: http://wiki.documentfoundation.org/ReleasePlan/3.6#3.6.2_release
You can see that no bugs were fixed against RC2.

Now, I have a question: we are fixing 3.6.2, but 3.6.3 is already out with many important bug fixes. Will this version make it to Quantal? Will it be tested with the patches applied to 3.6.2 and be updated soon?

Cheers

John Winterton (jwinterton) wrote :

@ Stéphane Guillou

Most interesting. Do they ever arrive at a stable release that is not labelled 'release candidate'? This usually means the product is at some level of final beta testing.

No: release candidate means that it is deemed ready for release unless something serious shows up. Thus the final release always is a RC too: the last one.

John Winterton (jwinterton) wrote :

Most fascinating. Darned funny semantics, too. A 'candidate' is not elected, if you like or even if you don't like. Suggests the program is so large and unwieldy that it can never really be out of testing.

Anyway, back to the subject of the operational menu: I have switched to the GNOME Classic desktop and there is no problem there with the LO menus. I consider this to be a sad but necessary regression.

mohican (mohican) wrote :

The "Window" menu is back with libreoffice 4.0 installed on Ubuntu 12.04 Precise, from ppa:libreoffice

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions