Livewallpaper doesn't start at login after upgrade to 15.04

Bug #1451171 reported by Riccardo Terzi on 2015-05-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LiveWallpaper
Undecided
Unassigned

Bug Description

I upgraded from Ubuntu 14.10 to Ubuntu 15.04
With the new OS version, after the login, Livewallpaper indicator still shows up and says it's activated (tick mark), but there is no animated desktop. To make it appear, I have to turn it off and turn it back on.

I tried to uninstall and reinstall Livewallpaper, but nothing changed.

Hi,

Could you please open a terminal and type livewallpaper so that we can see if any error message is displayed ?

Thank you

Riccardo Terzi (terzi-88) wrote :

Launching livewallpaper (or livewallpaper-indicator) shows no error message (it correctly starts the animated wallpaper):

rick@laptop:~$ livewallpaper
^C
rick@laptop:~$ livewallpaper-indicator
^C

Since the error occurs only at login, I thought that dmesg might show something, and in fact:

rick@laptop:~$ dmesg | grep livewallpaper
[ 78.944595] livewallpaper[2032]: segfault at 7f2f052cff38 ip 00007f3007c6d625 sp 00007fffdd25c200 error 4 in liblivewallpaper-core.so.0.5.0[7f3007c62000+f000]

Hope this helps.

Maximilian Schnarr (fyrmir) wrote :

Yes, that helps, but I need some more information. What wallpaper do you use? Do you have the same problem if you use an other live wallpaper plugin? What graphics card do you have?

Riccardo Terzi (terzi-88) wrote :

Ok, this is weird.

I was changing livewallpaper plugins (via the livewallpaper-indicator) and rebooting each time to see if the others (Noise is the one I use) were working or not. After trying them all I returned to Noise and rebooted again and - voilà - it works! :-|

And dmesg shows no error:

rick@laptop:~$ dmesg | grep livewallpaper
rick@laptop:~$

I don't know if this is permanent (I hope so), anyway here's the data you asked me:

The wallpaper in use is "Noise".
Gradient clock, Galaxy, and Nexus all work fine.
Circles and Photoslide start after a handful of seconds (almost 10 or so).

Graphic cards:

rick@laptop:~$ sudo lshw -c display
[sudo] password for rick:
  *-display
       description: VGA compatible controller
       product: GF108M [GeForce GT 540M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:50 memory:d0000000-d0ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:2000(size=128) memory:d1000000-d107ffff
  *-display
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:48 memory:d1400000-d17fffff memory:c0000000-cfffffff ioport:3000(size=64)

Riccardo Terzi (terzi-88) wrote :

It started acting up again... no idea why.

At the login it was disabled, I enabled it. Throughout the day I found that it disabled itself again (livewallpaper-indicator's tick mark was off), so I re-enabled it.

Here's dmesg's log:

rick@laptop:~$ dmesg | grep livewallpaper
[ 89.031795] livewallpaper[2047]: segfault at 7f7779be2e30 ip 00007f767e78f625 sp 00007fffde46f230 error 4 in liblivewallpaper-core.so.0.5.0[7f767e784000+f000]
[ 209.969446] livewallpaper[2423]: segfault at 7f9f66c231b4 ip 00007fa0695e7625 sp 00007fff78b1c9a0 error 4 in liblivewallpaper-core.so.0.5.0[7fa0695dc000+f000]
[ 5539.543661] livewallpaper[7138]: segfault at 7f5b89893c50 ip 00007f5a8db06625 sp 00007fffdd42a600 error 4 in liblivewallpaper-core.so.0.5.0[7f5a8dafb000+f000]
[12112.830764] livewallpaper[16890]: segfault at 7f66963051c0 ip 00007f659c53e625 sp 00007fff0d4e93d0 error 4 in liblivewallpaper-core.so.0.5.0[7f659c533000+f000]

I'll try again to do whatever I did that worked last time '_'

binsha (bins-mail) wrote :

my system is ubuntu 15.04 and I use gdb to trace the source code and find that when the noise plugin is deactivated and the noise particle system program is finalized, a double-free crush will be reported. I try to fix the double-free crush and test the switch between noise plugin and other plugins(through indicator), the crush problem doesn't happen again. I'm not sure if this fix will directly effect this bug but I still provide the patch in the attachment. Hope it can be helpful.
Below is the partial output from my gdb:

#6 0x00007ffff5f43361 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7 0x00007ffff7bd1ef9 in lw_program_finalize () from /usr/local/lib/liblivewallpaper-core.so.0.5.0
#8 0x00007ffff624a29a in g_object_unref () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#9 0x00007fffdb7146d5 in noise_particle_system_dispose () from /usr/local/lib/livewallpaper/plugins/noise/libnoise.so
#10 0x00007ffff624a225 in g_object_unref () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#11 0x00007fffdb7137b2 in noise_plugin_dispose () from /usr/local/lib/livewallpaper/plugins/noise/libnoise.so
#12 0x00007ffff624a225 in g_object_unref () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#13 0x0000000000405442 in lw_application_unload_wallpaper_plugin ()

binsha (bins-mail) wrote :

I've updated a new patch which provide a new clear function for the tex-units array. I think it can help to fix the double free crush when the particle system of the noise plugin is finailized.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers