Ubuntu live filesystem build scripts

[omap4] tasksel shows seeds unavailable in the preseed image

Reported by Michael Casadevall on 2012-04-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs
Fix Released
Medium
Unassigned

Bug Description

During installation on armel+omap4, tasksel shows seeds that are unavailable on the preinstalled images such as Kubuntu LiveCD. Installation was done with no network connectivity availabile, and these seeds are uninstallable without connectivity. In addition, I don't believe they should be listed at all for a server image, to be consistent with x86 (which does not show seeds that are unavailable on the CD).

Steps to Reproduce:
1. Proceed through the installer as normal
2. Check tasksel list when tasks are selected.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/985258

tags: added: iso-testing
Adam Conrad (adconrad) wrote :

This is a by-product of the preinstalled-package-pools thingee from last cycle not actually being fully implemented (I never got around to doing task generation).

Over the last cycle, I've not once had a user praise the availability of local packages, mind you, while many have whined about the image size exploding. I'm wondering if it might not be better to just drop the feature and shrink the ARM server images to a comfy size again.

Adam Conrad (adconrad) wrote :

I may have misread the bug originally, except I'm now even more confused than ever. Does this not happen in tasksel universally? (showing tasks that you can't get because you have no network)?

Adam Conrad (adconrad) wrote :

And I realise that the d-i server CD doesn't do this, but that's because its packages files are completely local, the omap Packages files are just the archive versions (plus its own weird ones), due to it being a livefs. This is exactly the behaviour you'd see on an installed system with the network unplugged, if you run tasksel.

Steve Langasek (vorlon) wrote :

This is not a bug in tasksel. Tasksel simply displays the tasks from the Packages files that it knows about. In the case of an x86 server install, it only knows about the packages that are present on the d-i-based CD. In the case of an armhf server preinstall image, it has pre-cached Packages files for all of the archive. So perhaps this is a bug in how we're choosing to build the images.

affects: tasksel (Ubuntu) → ubuntu-cdimage
Adam Conrad (adconrad) on 2012-04-19
affects: ubuntu-cdimage → livecd-rootfs
Changed in livecd-rootfs:
importance: Undecided → Medium
Adam Conrad (adconrad) wrote :

livecd-rootfs (2.65) precise; urgency=low

  * Add (extra-)override parsing to the preinstalled pool to make sure
    we get task headers in the local pool for tasksel (LP: #819899)
  * Move temp directories under config so they get cleaned properly
  * Invoke apt-get update once with only the sources.list fragment
    for the local archive, so our package/task selection more closely
    mimics the CD experience (LP: #985258, #985737, #985280, #819900)
  * Write out a standard sources.list entry for preinstalled systems
    that's similar to the one generated by installers (LP: #985291)

 -- Adam Conrad <email address hidden> Fri, 20 Apr 2012 00:29:38 -0600

Changed in livecd-rootfs:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers