login request failed: Server certificate verification failed: issuer is not trusted

Reported by István Váradi on 2011-03-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Live F1
Low
Dave Pusey

Bug Description

The message above is displayed when attempting to run either 0.2.8 or 0.2.10.

Related branches

Dave Pusey (davepusey) wrote :

Please could you double check which version of live-f1 you are running, and perhaps post a screenshot of the message.

I am unable to reproduce this with a freshly downloaded copy of 0.2.10

Changed in live-f1:
assignee: nobody → Dave Pusey (davepusey)
István Váradi (ivaradi) wrote :

I compiled the program from scratch using a libneon also compiled by myself, and it works now.

Formerly I tried with precompiled versions linked to libneon-gnutls on Ubuntu. Perhaps that libneon-gnutls was the problem.

Dave Pusey (davepusey) wrote :

Precompiled? Do you mean from the package library?

István Váradi (ivaradi) wrote :

Yes, installed with apt-get.

Dave Pusey (davepusey) wrote :

And what version of Ubuntu? what repositories?

István Váradi (ivaradi) wrote :

Ubuntu 10.10 and the Universe repository:

ftp.kfki.hu_linux_ubuntu_dists_maverick_Contents-amd64.gz:usr/bin/live-f1 universe/utils/live-f1

Dave Pusey (davepusey) wrote :

I'm just installing a test copy of 10.10 onto a VM now, so will have a look into it.

Dave Pusey (davepusey) wrote :

On a clean install of 10.10 (i386) it works fine. (using a local vmware virtual machine)

On a clean install of 10.10 (amd64) it works fine. (using Amazon EC2 platform as I don't have a 64-bit system to test on)

I think it's probably something specific to your machine.

Changed in live-f1:
status: New → Invalid
importance: Undecided → Low
István Váradi (ivaradi) wrote :

Yes, most likely.

Peter Tselios (livef1ng) wrote :

No, the problem is NOT machine specific. In my openSUSE 11.1, I had to recompile the 0.2.10 version in order to work. So, it is a "bug", but I do not know if it is libneon related or not.

Dave Pusey (davepusey) wrote :

Ok fair enough. With only one report and not being able to reproduce it seemed a machine specific issue. If you too are having the problem then clearly it isn't.

What I don't understand is why the error is happening at all, as use of ssl was disabled in 0.2.10 due to other reliabilty issues.

Changed in live-f1:
status: Invalid → Confirmed
Peter Tselios (livef1ng) wrote :

Are you sure about the SSL?
Anyway, I tried with 0.2.7 and 0.2.8 that I had in my 2 other PCs and all had the same behavior: After the fresh compilation, everything was OK. I believe that it is better to keep the SSL as an option, strictly. If SSL fails, then, go back to the un-encrypted page...

Dave Pusey (davepusey) wrote :

The use of SSL was actually causing a problem with intermittent hanging. Disabled it solved the problem.

Dave Pusey (davepusey) wrote :

Fixed in r110

Changed in live-f1:
milestone: none → 0.2.11
status: Confirmed → Fix Committed
Dave Pusey (davepusey) on 2011-03-27
Changed in live-f1:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers