PackageKit Daemon crash when I install using pkcon a IPK package

Bug #1361686 reported by Adrián Arroyo Calle on 2014-08-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Listaller
Undecided
Matthias Klumpp

Bug Description

PackageKit Daemon crash when I tried to install a IPK package using:

sudo pkcon install-local PACKAGE.ipk

Ubuntu 14.04
PackageKit release: 0.8.12-1ubuntu5

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: packagekit 0.8.12-1ubuntu5
ProcVersionSignature: Ubuntu 3.13.0-34.60-generic 3.13.11.4
Uname: Linux 3.13.0-34-generic i686
ApportVersion: 2.14.1-0ubuntu3.3
Architecture: i386
CurrentDesktop: Unity
Date: Tue Aug 26 07:24:22 2014
InstallationDate: Installed on 2014-04-19 (129 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20140417)
SourcePackage: packagekit
UpgradeStatus: No upgrade log present (probably fresh install)

Matthias Klumpp (ximion) wrote :

Interesting - do you mean a Listaller package with IPK package, or an Opkg package?

Changed in packagekit (Ubuntu):
assignee: nobody → Matthias Klumpp (ximion)

I've made a little change and now it shows another error. I've changed Version: 1.1 to 1.2 in the pkoptions file and it doesn't crash but says the following:

Error fatal: Framework Xorg XServer and applications is not installed! Please make it available to continue

but I'm using the default Unity desktop and I have X11 installed.

Matthias Klumpp (ximion) wrote :

Sounds like a Listaller message - you should not be able to install these with this PK version, but the service shiould also not crash.
Can you paste the output of apt-cache policy listaller here?
Where did you get the package from?

Matthias Klumpp (ximion) wrote :

What happens if you run
sudo lipa -i PKGNAME.ipk ?

affects: packagekit (Ubuntu) → listaller
Download full text (23.5 KiB)

It says: (12%) WARNING Framework 'Xorg XServer and applications' could not be found, reason: Library libxcb.so.* was not found and fails with the same error but I have installed libxcb libs. In fact the software that I was trying to package with Listaller was compiled on the same computer.

apt-cache policy listaller says:
listaller:
  Instalados: 0.5.8-2
  Candidato: 0.5.8-2
  Tabla de versión:
 *** 0.5.8-2 0
        500 http://ftp.udc.es/ubuntu/ trusty/universe i386 Packages
        100 /var/lib/dpkg/status

I tried also the old package (pkoptions 1.1) and crash lipa also. The screen is like that:
lipa(lipa_installer_run_setup+0xc3)[0x804d803]
lipa(lipa_tool_run+0x134)[0x804b1f4]
lipa(main+0xa2)[0x804aa92]
/lib/i386-linux-gnu/libc.so.6(__libc_start_main+0xf3)[0xb72e0a83]
lipa[0x804aaca]
======= Memory map: ========
08048000-08052000 r-xp 00000000 08:01 1064897 /usr/bin/lipa
08052000-08053000 r--p 00009000 08:01 1064897 /usr/bin/lipa
08053000-08054000 rw-p 0000a000 08:01 1064897 /usr/bin/lipa
09a71000-09b05000 rw-p 00000000 00:00 0 [heap]
b5b76000-b5b7d000 r-xp 00000000 08:01 359870 /lib/i386-linux-gnu/librt-2.19.so
b5b7d000-b5b7e000 r--p 00006000 08:01 359870 /lib/i386-linux-gnu/librt-2.19.so
b5b7e000-b5b7f000 rw-p 00007000 08:01 359870 /lib/i386-linux-gnu/librt-2.19.so
b5c49000-b5c74000 r-xp 00000000 08:01 1056473 /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so
b5c74000-b5c78000 r--p 0002a000 08:01 1056473 /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so
b5c78000-b5c79000 rw-p 0002e000 08:01 1056473 /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so
b5c79000-b5c92000 r-xp 00000000 08:01 1055917 /usr/lib/i386-linux-gnu/gio/modules/libgioremote-volume-monitor.so
b5c92000-b5c93000 ---p 00019000 08:01 1055917 /usr/lib/i386-linux-gnu/gio/modules/libgioremote-volume-monitor.so
b5c93000-b5c94000 r--p 00019000 08:01 1055917 /usr/lib/i386-linux-gnu/gio/modules/libgioremote-volume-monitor.so
b5c94000-b5c95000 rw-p 0001a000 08:01 1055917 /usr/lib/i386-linux-gnu/gio/modules/libgioremote-volume-monitor.so
b5c95000-b5cbb000 r--p 00000000 08:01 134333 /usr/share/locale-langpack/es/LC_MESSAGES/libc.mo
b5cbb000-b5cd7000 r-xp 00000000 08:01 263752 /lib/i386-linux-gnu/libgcc_s.so.1
b5cd7000-b5cd8000 r--p 0001b000 08:01 263752 /lib/i386-linux-gnu/libgcc_s.so.1
b5cd8000-b5cd9000 rw-p 0001c000 08:01 263752 /lib/i386-linux-gnu/libgcc_s.so.1
b5cd9000-b5dc0000 r-xp 00000000 08:01 1160174 /usr/lib/i386-linux-gnu/libstdc++.so.6.0.20
b5dc0000-b5dc1000 ---p 000e7000 08:01 1160174 /usr/lib/i386-linux-gnu/libstdc++.so.6.0.20
b5dc1000-b5dc5000 r--p 000e7000 08:01 1160174 /usr/lib/i386-linux-gnu/libstdc++.so.6.0.20
b5dc5000-b5dc6000 rw-p 000eb000 08:01 1160174 /usr/lib/i386-linux-gnu/libstdc++.so.6.0.20
b5dc6000-b5dcd000 rw-p 00000000 00:00 0
b5dcd000-b5deb000 r-xp 00000000 08:01 1054763 /usr/lib/i386-linux-gnu/libproxy.so.1.0.0
b5deb000-b5dec000 ---p 0001e000 08:01 1054763 /usr/lib/i386-linux-gnu/libproxy.so.1.0.0
b5dec000-b5ded000 r--p 0001e000 08:01 1054763 /usr/lib/i386-linux-gnu/libproxy.so.1.0.0
b5ded000-b5dee000 rw-p 0001f000 08:01 1054763 /usr/lib/i386-linux-gnu/libproxy.so....

Matthias Klumpp (ximion) wrote :

Okay :) Great that you're trying Listaller! Unfortunately it doesn't make that much sense to further debug this issue, since there have been many changes in the Listaller development branch and the IPK format.
This was mainly due to the merge of some Listaller concepts into AppStream[1][2].
Long story short: This change was highly disruptive for both projects - it broke AppStream API and Listaller as well. What we get long-term though, is better support for Listaller by upstream software and *much* better system integration.
What you will have to change in your packaging is mainly providing an AppData file for your application instead of a DOAP file (see [3]) and bump the IPK standard version to 2.0 (this is not backwards compatible, which really sucks since the format in itself has some countermeasures to extend it in a backwards-compatible way).
Then run lipkgen again.
Right now I don't recommend to use the Listaller master branch, since too many changes are happening, and it also requires a more recent version of PackageKit (previous ones had bugs as well...), but you can expect the new version in Debian Jessie (and Ubuntu, as soon as they migrate to PK 0.9.x).
I am working on getting all of that ready in time (and there will be some blogposts about how to create Listaller packages, although at the beginning it is recommended to statically link stuff packaged in IPK packages since the dependency-resolver will not be that clever at the beginning (will solve itself with more AppStream data becoming available)).
For the time being, you can fool Listaller by editing the file "/usr/share/listaller/components/frameworks/XOrg.framework" and removing the libraries which it fails to find ;-)

I am leaving this bug open (since it seems to be a valid issue), to see if it vanishes with a more recent version of LI :) (the next release will - depending on the level of API-stability we reach - be either 0.6 or 0.8.9. 0.6 means no more changes to the IPK format or any internal database (for the latter only if upgrade paths are available))

Cheers,
     Matthias

[1]: http://en.wikipedia.org/wiki/AppStream
[2]: http://www.freedesktop.org/software/appstream/docs/
[3]: http://www.freedesktop.org/software/appstream/docs/chap-Quickstart.html#sect-Quickstart-DesktopApps

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers